1. DavRoc's Avatar
    I'm having problems updating the OS on my unrooted, stock Nexus S I9020A, running on Straight Talk on an AT&T sim. When I purchased it, it was on 2.3.4. As soon as I turned it on (which was prior to the release ICS for this phone), it upgraded itself to 2.3.6 over WiFi via an OTA download. However when ICS came out, it did not upgrade itself OTA, despite waiting several weeks after the OTA appeared to be rolling out here in the US (since I got the 2.3.6 upgrade before I had even put the sim in, I assumed that the fact that I was on Straight Talk should not matter, but I'm not 100% clear on that). In any event, after getting tired of waiting, I updated the OS to ICS 4.0.4 manually by downloading the official OTA zip file manually, copying it to the phone, rebooting into recovery mode, and applying the update. Now that JB has been released, I've waited again for it to update automatically OTA, but no joy. So I again downloaded the official OTA zip file (this one: http://android.clients.google.com/pa...a/P2lZDQWb.zip), and tried to do it manually. This time, however, I get the following error each time:

    Finding update package . . .
    Opening update package . . .
    Verifying update package . . .
    Installing update . . .
    Verifying current system . . .
    assert failed: apply_patch_space (16570800)
    E:Error in /tmp/sideload/package.zip
    (Status 7)
    Installation aborted

    As far as I can tell, I'm using the correct file. Currently, from the bootloader my Product Name is Herring; Hardware Version is Rev. 16; Bootloader is ver. I9020XXKL1; Baseband Ver. is I9020UCKJ1; and Carrier Info is AT&T. In Settings, About Phone, it says my baseband is I9020AUCKJ1, and Kernel is 3.0.8-g665123, android-build@vpbs1 #1, Thus. Feb 2 16:56:02 PST 2012.

    I've also tried doing a full reset on the phone, but that doesn't help. Asking it to check for updates doesn't do anything, and I get the same error message when I tried to do it manually as described above after resetting.

    Any advice? Hate to be stuck on ICS. Many thanks.
    02-23-2013 03:31 PM

Similar Threads

  1. Update to Jelly Bean from ICS - how?
    By sids666 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 6
    Last Post: 01-09-2013, 09:51 AM
  2. Nexus won't properly update (173.8mb update) to Jelly Bean?
    By NewNexusUser99 in forum Sprint Galaxy Nexus
    Replies: 5
    Last Post: 10-18-2012, 06:50 AM
  3. Is the Wifi update to Jelly Bean a work around?
    By pauldroidr2d2 in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 10-01-2012, 04:50 AM
  4. Lost flash by updating to Jelly Bean?
    By jonsnowden in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 2
    Last Post: 09-21-2012, 09:04 PM
  5. Tried updating to Jelly Bean -- Stuck on Google screen / Bootloop
    By dmmarck in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 32
    Last Post: 08-28-2012, 11:09 PM
LINK TO POST COPIED TO CLIPBOARD