1. prakashgupta's Avatar
    I've a year old Samsung Google Nexus S with no accidents, problems so far, but ...

    One day at office the battery discharged completely and when I came back home and put it on charge. After half an hour I put on the power button and it showed some messages of starting up like safe mode and some other messages...but it did not show the home screen after a while instead went completely black.

    I have now tried options like Volume down + power button with 15 secs, 30 secs, 60 secs both while charging and unplugged, but no luck so far.

    Is it some problem with battery? or something else?? Please help, I'd want to get my phone back to work.
    02-16-2014 04:20 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! How old is the battery? It might simply be dead, especially if it completely discharged. Have you tried a new battery?
    02-16-2014 10:10 PM
  3. prakashgupta's Avatar
    The battery is just one year old. I've not tried a new battery, let me try one and see if it that works.
    02-18-2014 06:54 AM

Similar Threads

  1. How do I boot into recovery on my prestigio multipad 8.0 HD?
    By Mindaugas Kazlauskas in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 8
    Last Post: 09-23-2016, 11:57 AM
  2. Nexus 5 Camera
    By Pro Vickers in forum Google Nexus 5
    Replies: 23
    Last Post: 03-05-2014, 07:44 PM
  3. Huawei u8800 keeps restarting, can not start!
    By CursedChico in forum Huawei
    Replies: 2
    Last Post: 02-24-2014, 05:18 AM
  4. nexus 4 display issue
    By luigimati in forum Google Nexus 4
    Replies: 1
    Last Post: 02-16-2014, 01:03 PM