03-01-2017 02:10 AM
165 ... 567
tools
  1. Moltres_rider's Avatar
    I got a BRAND NEW tablet for Christmas and SAME problem!!!! Tried EVERYTHING listed here NONE fixed the problem!!!

    Posted via the Android Central App
    12-24-2014 11:17 PM
  2. Samith Hettiarachchi's Avatar
    I got a BRAND NEW tablet for Christmas and SAME problem!!!! Tried EVERYTHING listed here NONE fixed the problem!!!

    Posted via the Android Central App
    Goto settings->mobile networks->access point names and try restoring to defults if not working try clearing proxy address (IP) .that resoleved my prob
    12-28-2014 05:28 PM
  3. Yujin Crisologo's Avatar
    I am having the same issue, this is crazy but when I tried connecting to other wifi spots or using mobile data, it allows me to access Play Store app on my android device. The problem only occurs when using my home internet wifi. Can you please confirm if the problem persists when you're connected to other wifi spots.
    03-04-2015 02:11 AM
  4. Yulia Vaisman's Avatar
    The same problem.On data play store is working and on wifi not
    04-23-2015 06:35 AM
  5. Kie754's Avatar
    - Go to "Google play" web site.
    - Click "?" on the right upper corner. It leads you to "Google Play Help".
    - Type "connection timed out".
    - Click on "Connectivity requirements for Google Play". Read the instructions.
    It worked for me. I did everything in the previous posts including factory reset but nothing fixed the problem. When I just did - 2.Restart your router and mobile device. 3.Turn Airplane mode on and off. , voilà! it was fixed.
    I was trying to fix this all day long today reading a lot of other people's posts when nothing fixed the problem so when I found out how to fix it I just wanted to share it. Hope it will help many others. Good luck!
    04-29-2015 03:21 PM
  6. Keitht53's Avatar
    I've just purchased a Samsung Galaxy Tab Pro 10.1 and have exactly the same problem. I've gone through the process of restarting the router, restarting the tablet, Aircraft mode on and off but the problem persists. Any more ideas?
    06-07-2015 08:46 AM
  7. rodevine's Avatar
    I re-installed the OS on my S6 yesterday and everything worked fine until I re-installed Nova and suddenly I can't access the Play store ( "connection timed out")
    I turned off wifi and it worked. Turned on wifi and still working (for the moment).
    Same setup worked fine for me two days ago - Nova and wifi just wouldn't play nice this time for some reason. The wifi is my work network btw, and it can be a little.... temperamental.
    08-04-2015 05:53 AM
  8. NixonPlayz's Avatar
    I'm not able to connect to the play store.. It says "connection Timed Out"... Retry.. AT&T Samsung Note 3
    I have cleared the cache, data, force stop also uninstalled play store updates, Checked time and date, and everything else I can find in searches to do..
    The strange thing is it still auto updates and I can type in the search bar on the play store search option and open it that way...
    I've tried it with WiFi and network but nothing works.. Continue to get, "Connection Timed Out"... Retry..
    Running Nova Prime Launcher..
    I have done system backups in nova but not sure what I will loose if I do a restore..
    Any help appreciated...
    Thanks....
    I Solved it Just Go to Setting>Accounts>Then Chose The google or google play store i think The click it And chose youtr existing acc the just sync it and its work after sync just go to play store go to it may ask you something just click yes and the go to setting tap my apps or your installed games and apps just click and click both insttaled and updates and goto search bar just type any games and then it will popup and return to home screen of play store and its done it should work and if its work review me ok thanks
    10-24-2015 01:00 AM
  9. Hakan Usakli's Avatar
    To all the people that cannot get play store to work and get a message "Connection Timed Out - Retry" while attempting to connect via WIFI
    after trying the usual suggestions like checking date/time, clearing cache, reinstalling play store from apk etc - those are mostly all useless because they do not fix the real problem. I am both amused and surprized by the amount of misinformation.

    The source of the problem is very likely on your wifi router/modem for most people.

    Enable NAT Port Triggering for Port 5228 on TCP and UDP protocols. Inbound and outbound on your modem/router. Refer to the documentation of your device if you are not sure how to do this or contact someone that knows what they are doing with networks.
    Play store will not work without that port.

    Enjoy!

    Google Play Store- Connection Time Out- Retry?-untitled.png
    12-05-2015 05:19 PM
  10. JimZiii's Avatar
    It may be a general problem.

    Try removing the gmail account in Settings/Accounts. Then add a new account, same login, same password.
    Thank you, this worked for me. My next step would have been to reinstall gplay
    05-19-2016 11:31 AM
  11. AbdAllaH0's Avatar
    hey ,, I have the same problem here ,, I have Infinix X510 with marshmallow,,, I got an update with 5.5 mb size ,, after this update I can't log in play store,,, is there any solution ?
    06-16-2016 06:53 PM
  12. ne0x H's Avatar
    disconnect from wifi
    07-20-2016 10:51 AM
  13. ibassfrog's Avatar
    Hey folks!
    I've tried every possible options like airplane mode w/wifi on, delete account-add it back, new account, factory reset, wipe cache - reset from recovery etc..
    Today I've called my internet provider, they told me it's a compatibility issue, my modem (incl. wifi router) is running ipv6 and he changed to ipv4. Or something like that. So it's working fine! I'm not a network guru. So give it a try and make a call.
    07-22-2016 05:57 PM
  14. Shalinipriyajha's Avatar
    I m using moto g4 play
    My net is working and m using whatsapp twitter and fb.
    But m not able to open any link or even use Google Search engine. It says connection timed out. It works with Wi-Fi. It's a new phone Pls help
    09-20-2016 11:15 PM
  15. Kawaiikookie gaming's Avatar
    I have the same problem. I tried signing out of my google acc then back in and now it wont let me sign in for some reason. I feel your pain Mine won't even update though
    03-01-2017 02:10 AM
165 ... 567

Similar Threads

  1. TMO Note 3 not compatible with Google wallet
    By raju130000 in forum T-Mobile Samsung Galaxy Note 3
    Replies: 4
    Last Post: 02-26-2014, 04:46 PM
  2. Replies: 3
    Last Post: 02-24-2014, 02:22 PM
  3. Replies: 3
    Last Post: 02-23-2014, 11:32 AM
  4. google services problem
    By wres in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 02-23-2014, 09:43 AM
  5. Galaxy note II problem with connecting to wifi after upgrading to jelly bean
    By ANDREW AGANGA in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 02-22-2014, 06:58 AM
LINK TO POST COPIED TO CLIPBOARD