1. minanotti's Avatar
    Hello, I'm a new user and new to Android overall. I find the default text messaging app a bit odd but it could just be me. Is it normal that when you're searching for contact inside of the text messaging app to show contacts with a phone # and email addresses as individual search results? I'm simply trying to text them not email them?

    Steps I took to reproduce:
    1.) Open the native Samsung text messaging app.
    2.) Type in a name in the "enter recipient text field"
    3.) My results start to show names w/phone numbers as well as people w/only email addresses

    Why do contact w/email addresses show up but more importantly how do I stop this from happening? I only want to text them via the text app, not email them. BTW, all of my contacts are not stored on device or SIM. All info is hosted in cloud (Gmail Contacts)

    *SPECS: Samsung GS4 w/native text app and on ATT network.
    09-17-2013 06:21 PM
  2. Golfdriver97's Avatar
    Hello, I'm a new user and new to Android overall. I find the default text messaging app a bit odd but it could just be me. Is it normal that when you're searching for contact inside of the text messaging app to show contacts with a phone # and email addresses as individual search results? I'm simply trying to text them not email them?

    Steps I took to reproduce:
    1.) Open the native Samsung text messaging app.
    2.) Type in a name in the "enter recipient text field"
    3.) My results start to show names w/phone numbers as well as people w/only email addresses

    Why do contact w/email addresses show up but more importantly how do I stop this from happening? I only want to text them via the text app, not email them. BTW, all of my contacts are not stored on device or SIM. All info is hosted in cloud (Gmail Contacts)

    *SPECS: Samsung GS4 w/native text app and on ATT network.
    Welcome to the forums!
    You can go into Contacts>scroll down to the name, and swipe either to the left or right. One way is messaging and the other is calling.
    minanotti likes this.
    09-17-2013 06:29 PM
  3. minanotti's Avatar
    Thanks that's definitely a straight forward way to use the contacts app to then decide whether i want to call or text. But, my issue is when I decide to start from the Text Msg App and look up a contact. It's during that lookup process that the search results show both phone #'s and emails. That seems weird and I'm hoping there's a way to only show phone #'s as results. Perhaps it's some integrated thing where a user can send a text to a recipient's email address but if I wanted to email someone, I would've started off by opening the email app instead.
    09-17-2013 06:50 PM
  4. Golfdriver97's Avatar
    Thanks that's definitely a straight forward way to use the contacts app to then decide whether i want to call or text. But, my issue is when I decide to start from the Text Msg App and look up a contact. It's during that lookup process that the search results show both phone #'s and emails. That seems weird and I'm hoping there's a way to only show phone #'s as results. Perhaps it's some integrated thing where a user can send a text to a recipient's email address but if I wanted to email someone, I would've started off by opening the email app instead.
    I know it didn't really answer your question. I think the search is designed to find everything.

    Sent from a Slim 4.3 S3
    09-17-2013 06:58 PM
  5. andog88's Avatar
    Hello, I'm a new user and new to Android overall. I find the default text messaging app a bit odd but it could just be me. Is it normal that when you're searching for contact inside of the text messaging app to show contacts with a phone # and email addresses as individual search results? I'm simply trying to text them not email them?

    Steps I took to reproduce:
    1.) Open the native Samsung text messaging app.
    2.) Type in a name in the "enter recipient text field"
    3.) My results start to show names w/phone numbers as well as people w/only email addresses

    Why do contact w/email addresses show up but more importantly how do I stop this from happening? I only want to text them via the text app, not email them. BTW, all of my contacts are not stored on device or SIM. All info is hosted in cloud (Gmail Contacts)

    *SPECS: Samsung GS4 w/native text app and on ATT network.
    I just myself took care of this issue yesterday (got my s4 3 days ago) it was pretty annoying.

    click on the Contacts icon on your home screen

    then click on Groups, and all the emails and stuff are in "Not Assigned"
    Golfdriver97 likes this.
    09-18-2013 08:34 PM
  6. Golfdriver97's Avatar
    I just myself took care of this issue yesterday (got my s4 3 days ago) it was pretty annoying.

    click on the Contacts icon on your home screen

    then click on Groups, and all the emails and stuff are in "Not Assigned"
    Thanks for posting your solution. May prove useful to someone in the future.

    Sent from a Slim 4.3 S3
    09-18-2013 08:37 PM
  7. tbrown10's Avatar
    Is there a way to mass-move the not assigned contacts to "my contacts"? I have 177 "not assigned" contacts and it'll take forever for me to move all of them into the new group 1 by 1.

    Thank you!
    11-11-2013 10:24 PM
  8. Kristie1981's Avatar
    Does anyone know of an easier and faster way to move all these "not assigned" contacts because I have 690 "not assigned" and I will be doing this forever!!
    Also, why in the world did this change? I have had this phone since it first came out and never had an issues with this until this week. Very annoying that I all of the sudden need to be doing this.
    11-12-2013 04:15 PM
  9. datamungo's Avatar
    This is a new behaviour actually. And i find it incredibly annoying. The text app used to autocomplete by name, now it autocompletes by number. EXTREMELY ANNOYING if you are just trying to send a quick text.
    11-12-2013 05:30 PM
  10. n8ter#AC's Avatar
    Thanks that's definitely a straight forward way to use the contacts app to then decide whether i want to call or text. But, my issue is when I decide to start from the Text Msg App and look up a contact. It's during that lookup process that the search results show both phone #'s and emails. That seems weird and I'm hoping there's a way to only show phone #'s as results. Perhaps it's some integrated thing where a user can send a text to a recipient's email address but if I wanted to email someone, I would've started off by opening the email app instead.
    It makes sense because you actually can send SMS/MMS to an email address. It will appear on the other person's inbox as PhoneNumber@Carrier.Domain.com

    Don't see what the issue is :-P
    11-14-2013 10:51 PM
  11. lathamc's Avatar
    This is a new behaviour actually. And i find it incredibly annoying. The text app used to autocomplete by name, now it autocompletes by number. EXTREMELY ANNOYING if you are just trying to send a quick text.
    I had that issue. I turned off sync for all accoutnts, restarted my phone, turned sync back on and it was fixed. That issue bugged me to no end!

    Posted via Android Central App
    11-20-2013 09:25 PM
  12. Starks23's Avatar
    I had that issue. I turned off sync for all accoutnts, restarted my phone, turned sync back on and it was fixed. That issue bugged me to no end!

    Posted via Android Central App
    This fixed the issue on the wife's S4. I turned sync off for Google contacts restarted the phone and it worked the way it should. The issue started after the update to 4.3, or whatever the last update was (sprint).
    11-21-2013 10:05 PM
  13. naptownbuckeye's Avatar
    Thank you for helping me solve this problem. Your a God send. This issue was driving me completely nuts. I had an S3 and it got ruined and just got an S4. Never had problems with the contacts on the other phone like this, but I didn't have my addresses synced via Google Sync on my other phone either.

    So go to: Settings----> Google------->Click on your Google email address (showing the little green sync sign next to it-------->Go to Sync Contacts and uncheck the box.
    Restart your phone and now you should be able to text someone to their phone without the email address coming up.
    12-13-2013 11:35 AM
  14. John Taylor10's Avatar
    Thank you so very much for the detailed and concise instructions. I just upgraded from the Sam 2 to the Sam 4 today and I found this new idea of only putting E-Mail addresses instead of phone numbers in the box when you are trying to text is the height of stupidity. Are we not supposed to be going forwards and not backwards?

    Cheers pal.
    12-27-2013 10:26 AM
  15. oldskool1972's Avatar
    I have this problem too, but on a Galaxy S2 (GT-I9100). I've tried the synch off, restart, synch on options but it makes no difference. Any guidance on how to resolve this would be gratefully received as this is very annoying. Thanks in advance.
    06-03-2014 11:29 AM
  16. Michelle Nelson4's Avatar
    THANK YOU... I was so tired of seeing my Ex and the "woman" he left me for end up on my contact list
    11-19-2014 02:37 PM
  17. iwalmsley's Avatar
    The problem is that when you write a message then press 'contacts' it puts all contacts (phone nos, email & facebook ) up & it's impossible to distinguish which is which . This is a nuisance when you just want to send a text to a contact's phone number. Is it possible to set the phone to just put phone contacts up when accessing them through the message app ?
    01-08-2015 01:00 PM
  18. dankueck's Avatar
    This has bugged me also: usually I have the (stock) text app open, viewing texts, etc. replying to texts, etc. Then I want to compose a text in the text app which means I first have to choose the recipient(s). So I type in a name of a contact and every number and email address for that contact shows up and I then have to choose the actual mobile phone number that I want to send to. I shouldn't have to "hack"/modify my contacts in order to text more efficiently. Sometimes we may want to actually send a text to an email address, but for me, 99% of the time, I want to send a text to someone's mobile phone number. I'll keep checking around and trying the advice mentioned here, but it seems to me that a third-party text app might be a better solution. Show Samsung how to make a better text app! For example, there should be an option in the (stock) text app that says "When displaying contacts in the text app, show these types of contact details: [ ] primary mobile phone, [ ] all phone numbers, [ ] primary email, [ ] all emails, etc. Then the user chooses what kinds of contact numbers will display when searching in the recipient field while composing a text message.
    10-01-2015 03:00 PM
  19. lovemonkeysd's Avatar
    This has bugged me also: usually I have the (stock) text app open, viewing texts, etc. replying to texts, etc. Then I want to compose a text in the text app which means I first have to choose the recipient(s). So I type in a name of a contact and every number and email address for that contact shows up and I then have to choose the actual mobile phone number that I want to send to. I shouldn't have to "hack"/modify my contacts in order to text more efficiently. Sometimes we may want to actually send a text to an email address, but for me, 99% of the time, I want to send a text to someone's mobile phone number. I'll keep checking around and trying the advice mentioned here, but it seems to me that a third-party text app might be a better solution. Show Samsung how to make a better text app! For example, there should be an option in the (stock) text app that says "When displaying contacts in the text app, show these types of contact details: [ ] primary mobile phone, [ ] all phone numbers, [ ] primary email, [ ] all emails, etc. Then the user chooses what kinds of contact numbers will display when searching in the recipient field while composing a text message.
    I, too, only want mobile phone numbers to show up when choosing a contact in the stock text messaging app (Message+). I have accidentally sent texts to emails and home phones and this is annoying. The suggestions in the thread above don't seem to work on my Samsung s5. What is the solution?
    04-18-2016 06:35 PM
  20. ttulinsky's Avatar
    I can see how that is annoying.
    On my Moto X which is almost stock android I have the opposite problem--sometimes I want to send a text to an email address and there is no way to auto-complete an email or choose from your contacts--you must type in the email address manually, or copy and paste it from your Contacts. (It does do auto-complete for phone numbers).
    08-16-2016 11:21 PM

Similar Threads

  1. Contacts disappear on Samsung Galaxy S4
    By E92Vancouver in forum Samsung Galaxy S4
    Replies: 12
    Last Post: 10-10-2014, 01:01 PM
  2. Contacts disappear on Samsung Galaxy S4
    By E92Vancouver in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 10-04-2013, 06:00 AM
  3. Is anyone on the Edge program?
    By skatergirl in forum Motorola Droid MAXX
    Replies: 41
    Last Post: 09-26-2013, 04:13 PM
  4. Replies: 6
    Last Post: 09-18-2013, 12:50 PM
  5. Replies: 2
    Last Post: 09-17-2013, 09:38 PM
LINK TO POST COPIED TO CLIPBOARD