1. rlridgeway's Avatar
    I have a Samsung Galaxy S4 I337 running 4.2.2. I had some previous screen issues ( the screen was almost black) but had somehow got the screen working again.
    Tonight I attempted to download the upgrade to 4.3. I think the download completed but did not see any confirmation. I tried to restart the phone. I saw a box saying 4.3 would install. The phone shutdown. After several minutes(maybe 10) I tried to turn phone back on. All I got were some flickers. After a few more minutes, I pulled the battery and replaced it. I attempted to turn phone on a gain and the phone gaves a short vibration about every 3 seconds. It had been doing this for about 15 minutes. I turned phone off and it only flickers when power button pushed.

    Any help greatly appreciated.
    12-01-2013 09:50 PM
  2. rlridgeway's Avatar
    UPDATE
    The phone seems to be working fine (at least for now). The 4.3 update went through also and so far the phone works well.
    12-01-2013 10:25 PM

Similar Threads

  1. Moto G on ATT & Smart Phone Newbe questions.
    By desert turtle in forum Moto G (2013)
    Replies: 15
    Last Post: 01-31-2014, 11:01 AM
  2. Replies: 6
    Last Post: 12-10-2013, 11:58 AM
  3. Unable to lock phone after booting up
    By aeronium in forum Samsung Galaxy Note 3
    Replies: 2
    Last Post: 12-08-2013, 11:53 AM
  4. Note 3 and Galaxy Gear phone call issue
    By mhettrich in forum Samsung Galaxy Note 3
    Replies: 2
    Last Post: 12-02-2013, 12:36 AM
  5. Replies: 4
    Last Post: 12-01-2013, 09:49 PM
LINK TO POST COPIED TO CLIPBOARD