1. f355chris's Avatar
    Everything has been working fine for months with my Galaxy S4. Then, 2 days ago, I updated to lollipop via my home wifi - so it was working just fine. Immediately after updating, my phone won't connect to my home wifi. It It repeatedly tries to connect (says, "Connecting ...") but it never actually connects. It then says "Saved, Secured" under my home wifi network name in the Wi-Fi settings on my phone.
    I have tried resetting the phone (including by removing battery), resetting the router, resetting the modem; toggling wifi on/off; toggling airplane mode on/off; resetting router to factory settings; and pretty much everything short of a factory reset of the phone but nothing works. The wifi connection works on all my other devices so the modem & router are working just fine. Any help is greatly appreciated.
    04-29-2015 02:21 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi tap Menu>Advanced, and see if there is a Smart Network Switch option. Turn it off if present.
    04-29-2015 12:16 PM
  3. f355chris's Avatar
    Thanks! I tried this but didn't work. I got another router and it's working so I guess the lollipop update has problems with some routers. Mine was older so perhaps that was it.
    B. Diddy likes this.
    04-29-2015 06:08 PM
  4. avisur's Avatar
    This update really screwed me up. I HATE the new look and feel, the way the chrome tabs open and incognito tabs.
    I have soo much trouble watching Netflix or You Tube as the picture stays still and I can hear the audio. IT messed up wifi settings. Is there any way to go back to the old one ??
    05-05-2015 01:53 PM
  5. B. Diddy's Avatar
    This update really screwed me up. I HATE the new look and feel, the way the chrome tabs open and incognito tabs.
    I have soo much trouble watching Netflix or You Tube as the picture stays still and I can hear the audio. IT messed up wifi settings. Is there any way to go back to the old one ??
    Welcome to Android Central! Please consider starting a new thread with your question, or looking for a similar thread and contributing there. Your post isn't exactly related to the OP's question.
    05-05-2015 07:17 PM
  6. born2runfree's Avatar
    My boyfriend and I both have Galaxy S4s and we are both having EXACTLY the same problem.
    06-06-2015 10:41 AM
  7. born2runfree's Avatar
    This didn't fix the problem . . . I've tried everything that f355chris tried and so it looks like I have to go purchase a new router because of the lollipop upgrade.
    06-06-2015 10:44 AM
  8. nipp kiss's Avatar
    Motorolla Droid Turbo Android 5.1
    So I am yet another person having the Wifi wont connect issue. Previous version had no issues.
    Having played around for a bit I have found out that: Manually setting DNS etc did nothing.
    So I attempted to use the WPS Push button though the router I'm trying to connect to only has SES. Even though it doesn't connect it does find router and connects to it. Oddly it shows the name of router instead of SSID. It works 100% UNTIL it shows SSID name. of course at which point I can not get online any longer. So connection last about 15 seconds or so.

    Obviously this is an Android 5.1 issue and since it is already Oct (in 2 days)
    WTF has this not been fixed.

    I tried updating as someone mentioned 5.2 but no updates available is what phone said.
    09-29-2015 01:43 PM
  9. Amy Dinovo's Avatar
    Big fat ditto here. I can see every network in my neighborhood including my own but can't connect. Saved? Really? More like Nuked.
    10-02-2015 08:15 PM
  10. Physirus's Avatar
    Hi All,

    I have all these issues as well, I tired every setting in my router, etc....reset everything... nothing worked. Finally had success by turning my bluetooth off, then everything sudden started working?!?!

    Here are my router settings just fyi:
    Band: 2.4Ghz (B+G+N)
    Mode: Ap
    Channel Width: 20/40MHZ
    Control Sideband: Upper
    Channel Number: Auto (but i have read to avoid 12 & 13)
    WPS: Off
    Encryption WPA2(AES) ... not that this will make a difference

    Hope this helps!
    11-02-2015 02:18 AM
  11. JGCSydney's Avatar
    I also had the same problem - WiFi connections showing up as "saved" and not connecting since Android5.
    I also found switching off Bluetooth solved the problem and allowed me to connect - thank you.
    11-03-2015 04:30 AM
  12. Amy Dinovo's Avatar
    So I can't work in my home office with my bluetooth headset on unless I want to be disconnected from Wifi? So dumb. Yes, it appears to be working but jeez, what a stupid conflict and nothing being done to correct it. Six months since I checked in on this issue and no updates to the OS have fixed this?
    03-21-2016 10:53 AM
  13. ShippsAhoy's Avatar
    My son has a MotoX with 5.1 installed. Connecting to our home wifi has completely failed. We tried deleting/partitioning the cache, we tried rebooting in Safe Mode, we tried calling Xfinity support for our router settings (which temporarily helped), but now he can't connect to our home wifi at all. In the meantime, he's chewing up data on our data plan. Any other ideas??
    04-12-2016 04:30 PM
  14. Sgooter's Avatar
    My son has a MotoX with 5.1 installed. Connecting to our home wifi has completely failed. We tried deleting/partitioning the cache, we tried rebooting in Safe Mode, we tried calling Xfinity support for our router settings (which temporarily helped), but now he can't connect to our home wifi at all. In the meantime, he's chewing up data on our data plan. Any other ideas??
    Does the MotoX connect with any non-secure networks, such as at a shopping mall, Starbucks, Panera's? Does the MotoX "see" your router's ID/home network? If yes, then are you able to temporarily disable your router's password just to test whether the MotoX will connect to it and allow internet access? Also, try going into Airplane Mode on the MotoX, then activate the wi-fi, then see if the phone connects to the home network. These troubleshooting steps are intended to give some clues as to the source of the problem: router or password or the phone.
    04-13-2016 03:11 PM
  15. abx901's Avatar
    Turning bluetooth off worked for me too. Thanks for the tip!
    05-26-2016 01:23 AM

Similar Threads

  1. My google nexus 5 can't connect to Wifi
    By Huan Pua Pao in forum Ask a Question
    Replies: 2
    Last Post: 06-18-2015, 06:21 AM
  2. How to unlock lock screen on Samsung galaxy s5?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-29-2015, 12:54 PM
  3. music to device
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-29-2015, 12:46 PM
  4. Replies: 1
    Last Post: 04-29-2015, 12:43 PM
  5. Is it possible to customize lock/unlock sounds?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-29-2015, 01:21 AM
LINK TO POST COPIED TO CLIPBOARD