1. Goneeuro's Avatar
    So when I put a new contact into my phone it doesn't upload to Google. Is there a setting i need to change. Its a little annoying. I didn't realize it wasn't doing until i did a master reset and all my new contacts that i added were gone. So i added one and checked online and it wasn't there. How to I make this work. I don't want to have to add every contact online and wait for them to push to my phone. Sorry, new to this android thing.
    Francisco Nogueira likes this.
    10-13-2011 09:36 AM
  2. Jennuine03's Avatar
    I'm not sure of any other way, but you wouldn't necessarily have to wait for it to push to your phone. You could add the contact in google and then go to settings > accounts & sync > gmail > sync contacts and they'd come through then.

    I'm still learning the Droid, too. So there very well could be another way that I don't know of yet.
    10-13-2011 09:48 AM
  3. wla2000's Avatar
    I have the same problem with my Samsung Infuse. I can add contacts successfully at gmail.com on my computer, and they sync within moments to my phone. But I want to be able to add contacts on my phone and have them get stored at gmail.com. I've seen lots of talk about how to do this with HTC phones, but none of that seems to apply to my Samsung.

    If you can point me in the right direction I would appreciate it!
    11-27-2011 09:58 PM
  4. jbomb11's Avatar
    Same problem here with my droid charge.

    Sent from my SCH-I510 using Tapatalk
    11-27-2011 09:59 PM
  5. fightfan's Avatar
    I have an HTC Droid Incredible phone myself, so this might not apply to you. For me, when I add a contact, I have the option of adding as type "Phone" or type "Gmail." If I add it as a "Phone," it does NOT get synced up to my gmail account. Unfortunately, "Phone" is the default, and I have to remember to keep changing it to gmail.

    That being said, if backing up is more important than syncing, i.e. you don't need it available on your computer, you can just use a app. Lookout Security and Antivirus (Lookout Security & Antivirus for Android | AppBrain.com) does a lot more than just contact backup, but it's free. There might be other "lightweight" contact backup apps out there, but I just don't know any off the top of my head. Good luck!
    JohnLP likes this.
    11-27-2011 10:12 PM
  6. Duard's Avatar
    In "contacts" select menu> more> settings and look at "save new contacts to". Answer must be "google". If it is phone or sim, new contacts will not sync.

    after fixing this, select so contact and hit "edit". At the very top of the screen it will show you where the contact is stored. If it's phone or sim this contact will not sync. There's a way to export all your phone/sim contacts and re-import them to google but I haven't got it to work correctly - safest thing is to just re-enter them.
    artofdesign, wla2000 and dgolfnut like this.
    11-28-2011 12:12 AM
  7. dpomerance's Avatar
    Go to Settings > Accounts and Synch > and make sure auto-synch is on. I never have a problem with this function and it is in the cloud before I can even get to my computer and look it up.
    11-28-2011 12:40 PM
  8. artofdesign's Avatar
    In "contacts" select menu> more> settings and look at "save new contacts to". Answer must be "google". If it is phone or sim, new contacts will not sync.

    after fixing this, select so contact and hit "edit". At the very top of the screen it will show you where the contact is stored. If it's phone or sim this contact will not sync. There's a way to export all your phone/sim contacts and re-import them to google but I haven't got it to work correctly - safest thing is to just re-enter them.
    That's the trick. Awesome. Thanks.
    11-28-2011 03:43 PM
  9. Duard's Avatar
    Sure. Here's the test to tell if you are having this problem: On the phone, open Contacts and find a contact that was originally on Computer and got copied to phone. Make a change while on the phone. Also add a new contact while on the phone. Wait a little while and go to the computer. Go to
    http://contacts.google.com
    and look for your changes. If the changed contact was synched but the new one wasn't you need this fix.

    That's the trick. Awesome. Thanks.
    11-29-2011 06:01 AM
  10. wla2000's Avatar
    Duard: Thanks. There are lots of things buried in those menus! That worked and helped a lot.

    Sent from my SAMSUNG-SGH-I997 using Tapatalk
    11-29-2011 08:14 AM
  11. kmcochran's Avatar
    I'm helping my grandmother get her phone set up. I have the Moto Photon, so it's similar, but different. She had a few contacts already in the phone. I set her up with a gmail address and have it set to sync. I don't see any of her contacts showing up in her gmail account yet.

    Also, I added my contact info via her gmail account on the computer, and then synced it with her phone. It adds my info down at the bottom of the contacts under My Contacts, Google System Group. I wanted to put it up in the Family Group, but I don't see that option anywhere. Can we move my info to the Family Group? I'm trying to make things easy for her since she's 88 and spends half her time in the US and half of it in Mexico.

    I was hoping to be able to enter her contacts thru her gmail account, but if I can't move them into the groups to make things easier for her, then I'll just have to enter them manually on her phone (not an option I desire).

    Thanks!
    05-03-2012 07:10 PM
  12. chaadi's Avatar
    Hope this helps: I've been frustrated with this for days and tried everything... thank god I had a back up of I would have lost all my contacts.

    This is what you shall do (apologies to Walt Whitman, Leaves of Grass introduction...)

    All contacts must be saved as Google... in the Email settings there is a choice to save to phone or sim or google and if they are not saved to google they do not sync.

    It seems they also have to be assigned to My Contacts or some other group... if not assigned that are taken off the google account on the web.

    it means if you want a copy of everything on your web google account you will have to re-enter them. And that I am not doing tonight.

    It's all fun isn't it. Do you think the people who write these programs actually use them?


    Here is the full Walt Whitman intro I refer to if you are interested... if we did as he suggests there might not be any more wars... now that's a thought... it's all in one sentence so take a breath before you start but you will be pretty amazed when you get to the last few phrases... look for the "lashes" bit.


    This is what you shall do; Love the earth and sun and the animals, despise riches, give alms to every one that asks, stand up for the stupid and crazy, devote your income and labor to others, hate tyrants, argue not concerning God, have patience and indulgence toward the people, take off your hat to nothing known or unknown or to any man or number of men, go freely with powerful uneducated persons and with the young and with the mothers of families, read these leaves in the open air every season of every year of your life, re-examine all you have been told at school or church or in any book, dismiss whatever insults your own soul, and your very flesh shall be a great poem and have the richest fluency not only in its words but in the silent lines of its lips and face and between the lashes of your eyes and in every motion and joint of your body.
Walt Whitman, from the preface of Leaves of Grass.
    05-08-2012 02:25 AM
  13. kmcochran's Avatar
    Chaadi, thanks for your reply. If I do all that, can I move those google contacts into the preset groups on the phone? That's the more pressing issue I have right now. Thankfully, there are only a handful of contacts already entered into the phone, so entering them into google is not a huge task, but I don't want to move them if they can't be sorted into the "Friends," "Family," Work," etc categories.

    I realize that's not the only way to search through the contacts, but that's how my grandmother would like them to be sorted.
    05-09-2012 01:07 PM
  14. ep1963's Avatar
    Hope this helps: I've been frustrated with this for days and tried everything... thank god I had a back up of I would have lost all my contacts.

    This is what you shall do (apologies to Walt Whitman, Leaves of Grass introduction...)

    All contacts must be saved as Google... in the Email settings there is a choice to save to phone or sim or google and if they are not saved to google they do not sync.

    It seems they also have to be assigned to My Contacts or some other group... if not assigned that are taken off the google account on the web.

    it means if you want a copy of everything on your web google account you will have to re-enter them. And that I am not doing tonight.

    It's all fun isn't it. Do you think the people who write these programs actually use them?
    This is not right.

    The option is not in email but contacts.

    Once you have it set to save to google, all new contacts will be saved there, you don't have to assign a group.

    Further, if you want your existing contacts on google, you can export them from phone and import to google. You don't have to re-enter individually.
    05-09-2012 03:43 PM
  15. dpomerance's Avatar
    Enter them into your gmail account on your computer, much easier and they will download to the phone
    05-09-2012 07:22 PM
  16. kmcochran's Avatar
    My main question is: if I enter contacts into gmail, is there any way to put them into the Family, Friends, Word, etc groups on the phone once they've been synced?

    I tried just putting my contact info in gmail, then it synced with the phone, but when I went in to edit the contact to put it in the Family group, that option was not available. I was able to move contacts that were directly entered into the phone into those categories, but not the contact that was entered via gmail.
    05-10-2012 09:03 AM
  17. Jim666's Avatar
    Problem:
    Contacts typed on phone do not go to computer gmail contacts.
    Contacts typed on computer gmail contacts go to android.

    Solution.
    First, here is a sensible usage that I use.

    My usage.
    I want my contacts to be stored in my main gmail accounts.
    (The solution will work if instead gmail you use other provider.)
    That is to say, as soon as I type my new contact, it will go
    into gmail contact list.
    Here is how to achieve that.
    On Android do:
    1.
    main | phone | contacts | +new contact | just UNDER the new contact
    there is little triangle that if you touch that, it will be menu
    allowing to select who will be hosting your contacts | I select gmail.
    This way it will configure that any new contacts will be stored in gmail contacts.
    2.
    Then to see the right thing (only gmail contacts), do:
    main | phone | contacts | menu | contacts to display choose gmail only.

    Disclaimer:
    If you want to use SIM to store some contacts and gmail to store other
    contacts my solution is not applicable.
    If you will use my usage, my solution works.
    Note to Android designers of phone app, the triangle is a BAD idea, it should
    be under menu option.
    11-08-2013 04:36 AM
  18. cahls's Avatar
    Thanks Duard... Seems like with so many versions and updates that if the contact was not saved to Google (even if later became one or linked or merged)- then any local edit would cause sync lock up... Your post with my use of other Android WiFi devices that weren't phones made all this come to light...

    Posted via Android Central App
    Samsung Galaxy Note 10.1 2014 Edition (WiFi)
    Samsung Galaxy Tab 2 10.1 (WiFi)
    Samsung Galaxy S3 (AT&T)
    01-26-2014 12:31 AM
  19. JohnLP's Avatar
    That worked for me, Samsung Galaxy S6 on ATT, changing the default from "Phone" to "Google." Thanks!
    10-30-2015 03:39 PM
  20. ammar11013's Avatar
    ok so now the question is how to add phone nos without sync to google i have bluestack and don't want to sync phone nos thanks.
    02-14-2016 04:13 AM
  21. Francisco Nogueira's Avatar
    I just found out today that exactly the same behaviour was happening with me (web contacts -> android : OK; android -> web contacts : FAIL). I've always worked without any problem (the sync used to be instantaneous).

    Today I found out that sometime in the past, I've had switched to the web contacts "preview", where new contacts from android would sync, although wouldn't appear in the "Contacts" groups. Instead, they were falling into a "Other Personal Results" only. Searching contacts, would fail to show these new contacts.

    Sollution?! Reverting to "classic" (is it how it's called?) web contacts interface.

    DONE! SOLVED!
    03-15-2016 06:17 AM
LINK TO POST COPIED TO CLIPBOARD