1. stevemikez's Avatar
    I had a Captivate, but never tried Samsung Media Hub until I got the Infuse 4g. I purchased a movie with my $25 credit, but when I try to play the movie for the first time, an error notification pops up that says "Sorry, License Acquisition Failed".

    I tried Samsung's online chat help and was told to do a soft reset (remove battery for 30 seconds). Of course it didn't work.

    What should I do?!
    05-23-2011 10:58 PM
  2. jsntrenkler's Avatar
    Did you try a factory reset?
    05-24-2011 08:25 AM
  3. zhelf's Avatar
    try uninstalling and reinstalling the updates for the media hub

    menu->settings->applications-> all->media hub->uninstall updates

    then go into the market and reinstall the updates after a soft reset.

    or option two clear the cache in the media hub app soft reset then relaunch.
    05-24-2011 08:36 AM
  4. docSandS's Avatar
    I had the same problem, the Media Hub movies fail to load and clicking on the Sorry, License Acquisition Failed error window, opens a website saying 'You have used all your activations'. Called Samsung helpline (18889874357, option 1, then option 5) and of course they were no help at all, tech support reply "We do not have sufficient resources to resolve this problem" !! But hopefully it had been documented and they are working on a solution.
    06-07-2011 05:23 PM
  5. Terrigno's Avatar
    Its possible that the shady ATT Rep where you were at, took those activation codes from the retail boxes and used them up. Dont count this out. When I say its possible, It is very possible. I know a guy who actually told me about the idea. And he was an AT&T rep NO NAMES, NO NAMES lol
    06-07-2011 05:35 PM
  6. crysandjohn's Avatar
    If it is a samsung device you must first log into the media hub in order to view any videos. Hope this helps
    10-03-2011 08:08 PM
  7. xmen171's Avatar
    I had...an error notification pops up that says "Sorry, license acquisition failed."
    I had the same problem! The following worked for me: In Media Hub, go to "My Media." Press (without lifting your finger) the video that you have been trying to view. A pop-up window will appear. Press "Remove from this device." Then, try to view it again. You may need to re-download the video file, but this should do the trick. Good luck!
    10-26-2012 08:19 PM
  8. ksfrogman's Avatar
    Yep. This Media Hub is absolutely useless to me. The reason I purchase movies is so I can watch them anytime anywhere. However, if you're on an airplane with no WiFi or mobile connectivity, there is no way to acquire that damn license (required whenever you want to view the movie). So I cannot watch my downloaded movies on the airplane or when there is no Internet. I will not be buying any more movies on Media Hub!
    01-19-2013 11:39 AM