04-16-2017 05:15 AM
379 ... 89101112 ...
  1. techymarkbo's Avatar
    Thanks, this helped on my HTC One. Tried other fixes but none worked. Removing the account then adding it back helped.
    07-23-2013 07:31 PM
  2. Jwh1o1's Avatar
    For my LG Optimus S I did a data wipe from recovery menu and all is working great now. If you haven't found any fix yet You can always download an app backup program and install it manually back up your data and then do a factory reset. Hope this helps!
    07-24-2013 10:54 AM
  3. capt.ron's Avatar
    Deleting Google account worked for me on Galaxy Nexus.
    Snoww3d likes this.
    07-25-2013 02:40 PM
  4. nikhilg04's Avatar
    I can tell you that this issue happens mainly after stopping Google Services Framework (this is a practice that some people recommend in order to be able to get OTAs when delayed to be available for your phone).

    I had Android 4.2, but I was trying to get a recently released bug-fixing 4.2.1 update, so I just did this (stop Google Services Framework), but after updating Android and restarting my smartphone, I got that infamous [RPC:S-5:AEC-0] error when trying to get some updates for my apps.

    FThen I did what @rds says (removing/adding my Google account) and the problem has gone!

    Let me add: this is not the first time I get that error, but it is until now that I realize both the reason and the solution, so I'm sharing this with you.
    07-26-2013 01:02 AM
  5. Devlyn16's Avatar
    I updated my Nexus 10 to 4.3 then had this error [I stopped frame work in order to force the 4.3 update to come across so i probably am to blame for causing it], Wound up needing to delete the account to fix it.

    A couple of thoughts: I have multiple users on the tab, my other users were able to access the Play store to download/update fine. I can't help but wonder if these multiple users were at fault for not letting the Clear Cache, Clear Data and Force Stop for the various apps/services to work without Deleting the account.
    07-26-2013 08:39 AM
  6. coffeeba's Avatar
    I've just fixed my GNex 4.3 by cleaning cache, deleting data and forcing to stop the Play Service, Play Store, Services Framework and Market Feedback. After that deleted all my google accounts.

    Now it's good as new!
    07-27-2013 09:56 AM
  7. Dhiraj Rakheja's Avatar
    Awesome tips.. Worked for me!! Thanks a ton mate
    07-31-2013 10:40 AM
  8. psfportacio's Avatar
    this one worked for my samsung galaxy S4... thanks!
    07-31-2013 12:27 PM
  9. George Ioseliani's Avatar
    07-31-2013 02:37 PM
  10. christian dimayuga's Avatar
    07-31-2013 11:23 PM
  11. karst89's Avatar
    Thank You Kori..it worked for me....
    08-01-2013 09:07 AM
  12. Himanshukumar bhardwaj's Avatar
    Dear Android User if it is Error retrieving information from server.[RPC:S-5:AEC-0]
    yours Mobile and Note ......
    please Follow .. Setting > Google > removed account

    then Login Gmail Account your Problem sort out...
    08-02-2013 02:18 AM
  13. Matthew Porter1's Avatar
    can you help me and error
    08-02-2013 10:55 PM
  14. Matthew Porter1's Avatar
    error and can you help me
    08-02-2013 10:57 PM
  15. lookinin's Avatar
    Follow Post #142 exactly. It will work.
    Strangest thing, after upgrading to Jellybean 4.3 I could not get any apps to update. I was concerned about deleting my Google account, but since it's stored in the "cloud" it never really was deleted. Phew. So, as I said, follow the instructions on Post 142 and you should be golden. Thanks to the OP for taking the time to post the technique! Cheers.
    08-03-2013 08:38 AM
  16. Mark Onichabor's Avatar
    Nice... Worked for me.. Settings>>>accounts>>>google account>>>remove account and add again... Zappppp
    08-04-2013 03:51 PM
  17. Anujgupta's Avatar
    Thanks a lot. It works for me on nexus 7
    08-05-2013 11:16 AM
  18. Syed Umair's Avatar
    When iam trying to download games then getting above subject problem.
    Please solve my problem .
    Iam grait full to you..

    08-06-2013 05:29 PM
  19. DanoNH's Avatar
    On the Samsung Galaxy S3 that worked for me too!
    First remove your Google account, go to Settings and scroll down to Accounts then select Google. At the top where it shows your e-mail address tap it then at the bottom of the page tap Remove account. Ignore all the dire warnings and follow it through until it's gone.
    Now do the removal of the cache and data by going to Settings > Applications Manager >All and scroll down to Google Play Services. Tap this and Clear Cache, Clear Data and Force Stop.
    Now go back one step and do the same for Google Play store, Clear Cache, Clear Data and Force Stop. Now do it for Google Services Framework too.
    Go back to the main menu and select Add account then Existing account and sign in with your username (usually your e-mail address) and password and agree to all until the account is created.
    Now reboot the phone and viola! There will be a prompt about accepting Google terms, location settings etc. just agree and suddenly all your apps will be back and updating good as new!

    Many thanks to all who helped on this one!
    As many others have already indicated, you HAVE to delete your Google account on the mobile device, and then add it back again. You should also clear the relevant cache and data mentioned in the above quoted post by Fenderblender. You'll be greeted with permission requests for various installed Google components afterwards, and updating should work flawlessly!

    It's no big deal, and you should get all your apps, app data and sync settings back without issue.
    08-06-2013 11:32 PM
  20. Suzie Burge's Avatar
    You are a genius. Thanks!!!
    08-07-2013 12:15 AM
  21. Rachel Savage1's Avatar
    This is the only thing that worked for me.Thank you so much!
    08-07-2013 01:11 PM
  22. lgh's Avatar
    All these tips don't help plz help me I'm solo annoyed
    08-08-2013 03:33 AM
  23. jlewis622's Avatar
    I tried everything. This one worked! Thank you!!!
    08-09-2013 12:30 PM
  24. SAMyers's Avatar

    Somewhere I am missing the "clear cache". I have found where I can stop the service.
    08-11-2013 01:59 PM
  25. AmjadHussain's Avatar

    Go to settings- Application manager- All tabs- " Google play services" and clear data as well as cache. and reboot ur device and launch Google play. It'll work
    Go to Settings- Accounts- Delete ur existing account (dont wory it will remain in server) and close it.
    then open Play Store and Settings- Add Account- Add your old existing account details and restart Play store,
    to be assure just install any app...Iam sure any of that will work.

    All the best...
    08-11-2013 03:18 PM
379 ... 89101112 ...

Similar Threads

  1. Retrieving Contacts from broken phone
    By arhgoofy in forum Motorola Droid
    Replies: 42
    Last Post: 04-04-2016, 12:13 AM
  2. Retrieving information from the internet
    By tomroberts89 in forum Android App Inventor
    Replies: 1
    Last Post: 05-26-2012, 07:38 PM
  3. Mail Question: Delete Mail from Server
    By valueman in forum AT&T Captivate
    Replies: 8
    Last Post: 01-01-2012, 10:27 PM
  4. Email app that will delete mail from server?
    By razorwire in forum Android Apps
    Replies: 4
    Last Post: 08-18-2010, 08:35 PM
  5. Replies: 0
    Last Post: 11-16-2009, 05:00 PM