1. Danijayjay's Avatar
    I have a Samsung 12.2 wifi SM - P900 tablet and I am unable to download the twitter app on it. When I Go to the play store it says "your device isn't compatible with this version". Does anyone else have this problem and if so how did you solve it. Thank you
    07-02-2015 11:07 PM
  2. eams1986's Avatar
    maybe it is the phone system is a bit old and tries to update or also the second option would be to use the phone browser.
    07-13-2015 09:19 AM
  3. messinajr's Avatar
    Thanks for sharing!
    09-04-2015 12:04 PM

Similar Threads

  1. Replies: 15
    Last Post: 03-17-2016, 01:53 PM
  2. Not able to turn on advanced calling
    By nwcollins in forum Motorola Droid Turbo
    Replies: 5
    Last Post: 07-03-2015, 04:54 AM
  3. Has anyone taken a project fi phone on a trip outside the US?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-03-2015, 12:39 AM
  4. Replies: 1
    Last Post: 07-02-2015, 10:16 PM