“Can’t connect to the internet” — Account Issues with Pixel 3a

  • Thread starter Android Central Question
  • Start date

Android Central Question

My son has my old Pixel 3a. My son is 12 years old, so his Google account is supervised through Family Link.

A few months ago (when he updated to Android 12, perhaps), all the Google apps on his phone quit working. They would crash when opening, which means that he cannot access Google Play Store or install updates of other apps.

Additionally, Google One, Account Settings, etc. Don’t work.

When I try to use his phone to look at “Manage Your Account”, a white screen and the spinner shows up along with the text, “Can’t connect to the internet. Some info may be outdated or not show. Refresh when you’re back online.”

Similarly, when Play Store is opened, we see “Authentication is required. You need to sign into your Google Account.”

Often, these apps crash after a few seconds of displaying these messages.

Now, his internet works; he can stream Netflix, etc. So we know he is connected to the internet.

Here’s a list of the things I’ve tried to do.

Deleted all apps that we could delete.
Cleared cache and data from all remaining apps.
Removed updates of the apps that gave me the option. (NOTE: Google app won’t let me “uninstall updates”, it says “Uninstall unsuccessful” whenever I try.)
Restarted the phone.
Reset Bluetooth and wifi.
Disabled and re-enabled Android System WebView
I’ve tried but failed at restarting in Safe Mode. I’ve tried it several times: long-pressed the Power Off button but wouldn’t work; tried the alternative method of turning it off, turning it on, and then holding Volume Down while the logo was showing. It won’t restart in safe mode. (The “Power Off” button won’t let me long-press it…the option menu just goes away.)

The two things I wish I could try are:

1) Remove my son’s account from the phone and re-add it. 2) Factory reset the device

Neither is allowed because it requires the Admin (my wife) to do it. Using the Family Link app, my wife chose to factory reset my son’s device. However, since his phone won’t connect to the Google services, his phone won’t respond to what the admin does. (I tested this with the “Play sound” option — where the supervisor can cause the supervised device to play a sound…I presume to help find it or to alert the kid — but it wouldn’t play the sound.)

I don't know what to do at this point. I’ve read countless threads and articles about issues bordering on our issues. The solutions either don’t work or aren’t available because of the Family Link supervision (and the lack of connection to Google services means that no Family Link changes will affect the phone, apparently).

Anyone know what to do?