A21 forces reboot to find carrier over wi-fi

heticu7

Member
May 20, 2023
7
7
3
Visit site
Hello all.

I am retired and live in my RV full time, in the Redwoods, CA. I have an A21, since summer of 2020. It has functioned fine until I moved to an RV park last October in an area with no cell coverage in range.

The park owners, who also live here in their RV, provide internet service via Starlink. They told me that if I turn on wi-fi calling on my phone, I can use the Starlink wi-fi to connect to Verizon. After learning how to do this, and rebooting the phone, it worked.... at first.

However, the Starlink has uplink connection issues from time to time: weather, hardware glitches, satellite acquisition, etc. Sometimes when that signal gets disrupted, my phone loses it's connection to Verizon, and goes into endless searching mode. The only way I have found to reacquire the Verizon signal is to reboot the phone. This has been going on since last October, and has become old, to say the least.

The park owners have iPhones, and have never had to reboot their phone to reacquire (they have Verizon also). This has caused me to do a lot of research comparing Samsung phones, iPhone vs Samsung, etc. I would like to keep my A21, as it's not that old and serves my purposes fine.

So my questions are:
Does anyone have experience correcting this issue, and if so, what hidden, buried setting do I change to make the phone automatically reacquire over wi-fi when the signal gets lost? Or, does someone know that it is the A21, with a hardware flaw, and can confirm that upgrading my phone will resolve the issue?

Thanks!
 
Last edited:

heticu7

Member
May 20, 2023
7
7
3
Visit site
I can't tell from your screenshot (it's covered up) but that option is under the label "Roaming Network Preference" on my phone. And yes, it is set to "Wi-fi preferred", and has been since day one. Is there another place to change that preference?
 
  • Like
Reactions: Laura Knotek

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
11,587
3,427
113
Visit site
I can't tell from your screenshot (it's covered up) but that option is under the label "Roaming Network Preference" on my phone. And yes, it is set to "Wi-fi preferred", and has been since day one. Is there another place to change that preference?
Yes, that's under "roaming network preference". I'm not sure if there are any other settings that would help you. I live in the city and use cable broadband Internet from Spectrum, and I have 5G cell service here. I'm sorry, but I've never encountered satellite Internet. Hopefully someone else will be familiar with it.
 
  • Like
Reactions: mustang7757

heticu7

Member
May 20, 2023
7
7
3
Visit site
Yes, that's under "roaming network preference". I'm not sure if there are any other settings that would help you. I live in the city and use cable broadband Internet from Spectrum, and I have 5G cell service here. I'm sorry, but I've never encountered satellite Internet. Hopefully someone else will be familiar with it.

Thank you for your input. Sometimes getting confirmation on what I have already done helps me know if I am on the right path or not.
 
  • Like
Reactions: Laura Knotek

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,015
4,073
113
Visit site
Welcome to Android Central! Have you tried turning on Airplane Mode, then making sure wi-fi is still on, and seeing if wi-fi calling still works? I recall being able to do this on my phones back when my workplace had horrible cell reception. It might prevent the phone from trying to search for the lost cell connection.
 
  • Like
Reactions: Laura Knotek

heticu7

Member
May 20, 2023
7
7
3
Visit site
Welcome to Android Central! Have you tried turning on Airplane Mode, then making sure wi-fi is still on, and seeing if wi-fi calling still works? I recall being able to do this on my phones back when my workplace had horrible cell reception. It might prevent the phone from trying to search for the lost cell connection.
That didn't work either. When I turned on Airplane Mode, it automatically turned off wi-fi. When I tried to make a call, it asked: "Turn off Airplane mode to connect wi-fi?" I hit yes, and it did all that. And made the call.

But, I was already still connected to Verizon via wi-fi, so I don't think this test proved anything. But thanks! Every little bit helps in seeing what will and will not work.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,015
4,073
113
Visit site
You should still be able to manually turn wi-fi on while Airplane Mode is on. Older versions of Android would automatically turn off wi-fi when Airplane Mode was toggled on, but I think that changed with Android 13, such that wi-fi stays on even when Airplane Mode is toggled. This was likely spurred by the fact that many airlines have wi-fi onboard now, and therefore allow wi-fi to be used.

So after turning on Airplane Mode, swipe down your Quick Settings and tap the Wi-fi button, and see if that helps.
 
  • Like
Reactions: Laura Knotek

heticu7

Member
May 20, 2023
7
7
3
Visit site
Okay! That did work. I turned on Airplane mode, it turned off wi-fi, I turned wi-fi back on, Airplane mode stayed on, and I was able to make a call. So what you are saying is that if I leave my phone in Airplane mode always, except when I go to town and enter cell range, then when the Starlink loses connection to Verizon (for whatever reason) my phone will not start searching for cell coverage, but will keep waiting for the connection to Verizon to come back via wi-fi. Right?

I can live with that! I'll have to test this theory over the next few days to see if I lose Verizon again, but still have the phone set up this way.

Again, thanks for this info! As Sherlock said: "Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth." :)
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,015
4,073
113
Visit site
Okay! That did work. I turned on Airplane mode, it turned off wi-fi, I turned wi-fi back on, Airplane mode stayed on, and I was able to make a call. So what you are saying is that if I leave my phone in Airplane mode always, except when I go to town and enter cell range, then when the Starlink loses connection to Verizon (for whatever reason) my phone will not start searching for cell coverage, but will keep waiting for the connection to Verizon to come back via wi-fi. Right?

I can live with that! I'll have to test this theory over the next few days to see if I lose Verizon again, but still have the phone set up this way.

Again, thanks for this info! As Sherlock said: "Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth." :)
That's exactly what I'm suggesting! 😁 Hopefully that works for you.
 
  • Like
Reactions: Laura Knotek

heticu7

Member
May 20, 2023
7
7
3
Visit site
Thanks again, guys. It looks like this is going to work fine. Last night the Starlink lost satellite connection for a bit, and when I looked at the phone, instead of it saying "Verizon Wireless" on the lock screen, it said "Airplane Mode". When the Starlink came back online a few minutes later, the phone reacquired the Verizon connection almost as soon as I got internet back. Awesome!
 

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
11,587
3,427
113
Visit site
Thanks again, guys. It looks like this is going to work fine. Last night the Starlink lost satellite connection for a bit, and when I looked at the phone, instead of it saying "Verizon Wireless" on the lock screen, it said "Airplane Mode". When the Starlink came back online a few minutes later, the phone reacquired the Verizon connection almost as soon as I got internet back. Awesome!
I'm glad you got it sorted.
 
  • Like
Reactions: mustang7757

heticu7

Member
May 20, 2023
7
7
3
Visit site
Well, sorry to say this Airplane mode process only lasted a couple of days. The A21 went back to forcing me to reboot to reacquire.

This led me to conclude that the A21 hardware was at fault, so as of yesterday I ported my number from Verizon to US Cellular and bought an S23+ in the process. So far, the S23+ is working flawlessly in the park with Starlink. When the Starlink wigs out for a bit, the S23+ "searches for service" and when wi-fi comes back online, the S23+ reacquires US Cellular within a couple of minutes. And no Airplane mode required. :)

This was a win-win deal for me: The S23+ is way faster, functions way better, and the hardware and tech is way better all around. And my monthly bill with USC is pretty much the same as what I was paying at Verizon, but the USC monthly bill includes the S23+ amortized over 36 months. Once I pay that off (and there is no contract, and I can pay it off whenever I want) the monthly bill goes down to much lower than Verizon.

So it turns out this whole connection issue was hardware specific. But thanks all for helping me work through this, as your input is what made the final deductions conclusive. :)
 
  • Like
Reactions: B. Diddy

Forum statistics

Threads
941,623
Messages
6,909,761
Members
3,157,994
Latest member
nwh212