After 4.3 update, sometimes wifi randomly stuck at "Obtaining IP address..."


AC Question

Hi all.

Phone: Samsung Galaxy S3 (T-Mobile)
User experience level: Expert
Root?: Not when issue started, rooted now and issue still persisting.

- After 4.3 update, sometimes my phone disconnects from wifi, and won't reconnect successfully. In the wifi connection screen I see it is stuck at "Obtaining IP address..."
- There's no reason to think rooting the phone caused the issue, as it started happening before rooting.
- Issue occurs randomly with any/all wifi access points, not just my home one for example. Rebooting wifi router is not a solution.
- I wanted to note, it is not looping connection then "Obtaining IP address..." and reconnecting, it is just sitting at "Obtaining IP address..." and not changing.

About two months ago, I clicked software update in my GS3's settings and it found the 4.3 update. I was excited and I did the update. Sadly, the 4.3 update made my phone into a piece of crap. Everything seemed a bit slower and the battery lasted like half as long as normal for some reason. I found out that was mostly because of Samsung's damn Knox app that I DIDN'T EVEN KNOW WAS INSTALLED AND I NEVER EVEN OPENED. Anyway, the phone was not rooted at this point and my wifi started to disconnect and sit at "Obtaining IP address..." once in awhile. I'd guess it happens about...twice a day on average? I look down and notice I'm not on wifi for some reason, and when I go to wifi selection screen, it says it's connected to the correct access point, but its just stuck at "Obtaining IP address...". After I realized it wasn't going to stop, I started Googling around and didn't find a ton of info on it. I've read that some people have a similar issue where their phone loops through reconnecting, then "Obtaining IP address...", then reconnecting, and so on, but mine isn't looping. Also, most of the similar issues were solved with a router reboot because the users were on their home wifi. I EXPERIENCE THIS ISSUE ON ANY/ALL WIFI ACCESS POINTS. Doesn't matter if I'm at home or work or a friend's house or Starbucks. Every once in awhile I get disconnected from wifi and it is just stuck at "Obtaining IP address...".
When I first noticed the problem, it seemed that toggling wifi off, then back on again helped remedy the issue, but now I see its more random, and toggling wifi may or may not solve the problem. More often than not, it doesn't. Toggling wifi forces the phone to attempt to reconnect with the wifi access point, and it does connect to it, but stops again at "Obtaining IP address...". Then, eventually/randomly, it reconnects fine to wifi.
Right now, as I type this, I was on wifi about 45 minutes ago, and just about 10 minutes ago I noticed I'm no longer connected, and it's still just saying "Obtaining IP address...".
So I was running the 4.3 update unrooted for a month or so and decided I was fed up with the crappy battery life and decided to root the phone to help improve the CPU usage hopefully to save the battery life. Like many Samsung phone owners, I found out that the reason for the excessive decrease in battery performance was thanks mostly to the Knox app that Samsung [and the NSA] bundled into their 4.3 update. If you're not familiar with the app, I recommend reading up on it for a good laugh. The app doesn't allow rooting the phone, so you have to manually flash an app that uninstalls the Knox app, and then you can root the phone successfully. Sure enough, after many different methods/attempts, I had to manually flash the Knox uninstall app, and then I successfully got root. After I uninstalled Knox, the phone went right back to its previous performance. The battery worked all day like it used to and everything is great (not to mention that I now have root so I could turn the CPU up a little bit for some better performance on a third generation phone). However, the wifi disconnect issue persists and is still occurring on a day-to-day basis.

If anyone has any ideas on possible solutions to my wifi disconnect/"Obtaining IP address..." issue, I'm all ears!
Thanks for reading.

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Welcome to Android Central, and yikes, that's unfortunate. I assume you've already tried a cache partition wipe? Have you contacted Samsung about this? It's their update, so if it messed up your phone, they would hopefully offer to do something about it.


Retired Moderator
Feb 12, 2012
Visit site
Try the Samsung Experience Center (the Samsung desk at Best Buy). They may have other ideas, but I think a reflash of 4.3 will fix things. The S3 4.3 OTA update had a few issues, and the modem (which handles the wifi hardware) was one of them. The other option would be your carrier's repair center, if they have a good one - same fix, a reflash. (Shouldn't do anything to your apps or data but back up just in case.)


New member
Oct 30, 2013
Visit site
OP here.
Thanks for the ideas, but I'm weary of taking the phone into a b&m place, as I assume the first question they always ask is "Did you root it?" and when I say yes (or they inevitably open the app drawer and see the SuperSU app installed), they'll recite a very practiced, "Rooting the phone voids the warranty and therefore we cannot help you." and/or "Rooting the phone changes a lot of internal configurations that you aren't supposed to touch, and therefore may have affected your WiFi functionality." even though the problem existed before I rooted it.
Last night I finally put CyanogenMod 11 on it and I've been playing with it so far today without the WiFi issue showing its nasty head. I don't know how exactly that could have fixed the issue, but I'll take it either way. We'll see if the issue comes back.

Still thankful for any recommendations and testaments here, keep them coming if you have them.
Thanks! ^_^

Trending Posts

Forum statistics

Latest member