After routine reboot, home screen won't load, phone keeps crashing, won't enter safe mode


New member
Jun 8, 2017
Visit site
I performed a routine reboot today because I hadn't done so in about a week, but when my phone came back on, suddenly a bunch of things weren't working anymore.

The first thing I noticed was that the font on the unlock screen was oversized. I was able to punch in my PIN and log in initially, but my home screen widgets were completely gone, and whenever I tried to click the single "Apps" button at the bottom of the screen, it wouldn't respond, and the screen would go black. I opened the settings to see if I could change the performance mode, but it kept saying that "settings had stopped" and wouldn't let me change anything. I also kept getting the "TouchWiz home keeps stopping" pop-up, but there there was nothing labeled "TouchWiz" in my applications that I could force stop.

I tried rebooting again, and now the screen won't stay lit even long enough for me to punch in my PIN to get into the phone, and when I try to hold down the power button to enter safe mode, it doesn't respond, and just keeps popping up the unlock screen for a few seconds before going black again.

Any ideas? My battery is at 50% right now, and there was no physical/water/any other kind of damage to the phone recently that I can remember.


Well-known member
Mar 22, 2011
Visit site
Welcome to the forum as a new member! If you can make sure you phone is off I would plug it in and charge it up. Then go to the bootloader and clear the system cache, then reboot and see what you have.

If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Android Central.

Forum statistics

Latest member