All Rooting methods persistently Failed on Samsung Galaxy S5 G900H


New member
Dec 12, 2013
Visit site
Device: Galaxy S6 G900H
ROM: First Lollipop 5.0 then KitKat 4.4.2
Problem: Unable to root phone and install custom recovery
Rooting methods tried: 1.Odin 3.09 (and 3.07 after 3.09 failed). It got this message:

<ID:0/007> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> CF-Auto-Root-k3g-k3gxx-smg900h.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/007> Odin v.3 engine (ID:7)..
<ID:0/007> File analysis..
<ID:0/007> SetupConnection..
<ID:0/007> Initialzation..
<ID:0/007> Get PIT for mapping..
<ID:0/007> Firmware update start..
<ID:0/007> SingleDownload.
<ID:0/007> recovery.img
<ID:0/007> NAND Write Start!!
<ID:0/007> FAIL!
<ID:0/007> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

2.ADB method in Ubuntu Linus as delineated in this thread: http Sorry, forum rules forbid newbies from posting links. I followed the instructions up to the point when the phone was put in recovery, thereafter the phone did not show up in the Nautillus file browser.
4.KINGO Root. This always reported success, but Root checker says there is no root. Titanium backup failed to work because there was no root
5.OneClick Root also failed
6.SRSRoot for Android also failed
7.Skipsoft Android Toolkit (Which I paid for) also failed . I contacted the developer through G+ and Twitter and E-mail, but he has not replied
After trying all these methods in LOLLIPOP (and knowing I had enjoyed ROOT in Kitkat before moving on to Lollipop) , I flashed back to KITKAT 4.4.2, and rooting with Odin and all the other methods failed also. Please, note that I had enjoyed rooting on the phone for more than a year, before upgrading to Lollipop 5.0 (BOAD).
Finally, Rooting through Stock Recovery using Phil_Touch also failed at "E-whole file verification failed".
I don't know what to do again. Can someone help please?


New member
Mar 21, 2015
Visit site
I have most of those issues also. I cant use Odin as I have a Linux machine. So I tried Heimdall, and I get an error "Cant download pit" or something like that. Can someone please shed us some light?

Trending Posts

Forum statistics

Latest member