Android 8.0 upgrade broke DND

Shari9352

New member
Jul 6, 2018
1
0
0
Visit site
I tried to post this in the thread pertaining to DND problems with Android 8.0 but it wouldn't let me post to "old content"! I just upgraded to 8.0 on June 21.

I used the standard DND modes for Android 7 all the time on my Moto Droid Z. I could just enable 1 hour if I was in a class, or before bed, I'd enable DND to go off at the next alarm in the morning. These were easy, no-brainer modes, and worked perfectly. Now, once you've created the 1 hour rule, you have to change the start and stop times manually if you have a class or go to a movie at a different time than the last time. What a pain.

For the "DND until the next alarm" mode, I created a rule named Alarm with the following settings:

Days: Sun-Sat
Start Time: 11 PM
End Time: 9 AM the next day
DND Preferences: Priority Only
Alarm can override end time (Stop at the end time or next alarm, whichever comes first): ON

The "Priority only allows" screen has Alarms, Reminders, and Events all enabled, so DND Preferences set to Priority Only should turn off DND in the case of any Alarms, Reminders, or Events between 11 PM and 9 AM, right? (Oddly, Alarms is set but grayed out, so I couldn't be turned off anyway, which seems weird.)

This did not work. At 11 PM, DND turned on as expected, but my alarm was set to trigger at 7:45 AM the next day. I woke up at 8:15 with the screen showing the alarm going for a half hour but no sound. DND was still ON.

I changed DND Preferences to Alarms Only. Same problem.

I further tested DND by changing the Alarm Rule’s Start Time to 1 minute from current time, setting DND Preferences to Priority Only and creating a reminder for 5 minutes from current time. At current time + 1 minute, DND turned on. So far, so good.

However, I expected DND to turn off in response to the reminder 5 minutes later and the reminder notification would sound. This did not occur. The reminder icon popped up, but the notification didn’t sound. I'm assuming it fails the same way for Events, too.

It worked perfectly before the upgrade. Am I doing something wrong or is it broken?
 
Last edited:

Forum statistics

Threads
942,991
Messages
6,916,771
Members
3,158,765
Latest member
gofuckyourselfandroid