Android Auto not working right with Volvo XC60

dkny330

New member
Oct 19, 2014
2
0
0
Visit site
Hi there - picked up my 2018 XC60 yesterday and having issues with Android Auto phone functions working. In my Ford I can control all phone functions through Android Auto and even send text messages which is incredibly helpful. When connected in the Volvo it will play music but disconnects the phone function for both calls and texts, navigation through Waze, etc. Have Samsung Galaxy S9+.

Attaching a few pictures to illustrate problem: 1) 3rd tile shows phone disconnected for some reason for phone functions, which makes all the important features (texting, Waze, etc) unusable. 2) 4th tile shows Android Auto connecting to car and displaying phone though. Not sure why phone functions are not working. Hope this is an easy fix! Thanks!
 

Attachments

  • Volvo Screen Phone Disconnected.jpg
    Volvo Screen Phone Disconnected.jpg
    256.8 KB · Views: 8
  • Volvo 4 tiles.jpg
    Volvo 4 tiles.jpg
    465.5 KB · Views: 8

mdobin

Member
May 18, 2016
12
0
0
Visit site
I also have a 2018 xc60. I believe the confusion is that, once your connected by cable, AA controls the phone function. you will use the phone function in the bottom tile one the cat see your phone connected to the cable.
 

epicshooter

New member
Apr 11, 2013
3
0
0
Visit site
Re: Android Auto not workingright with Volvo XC60

Hi there - picked up my 2018 XC60 yesterday and having issues with Android Auto phone functions working. In my Ford I can control all phone functions through Android Auto and even send text messages which is incredibly helpful. When connected in the Volvo it will play music but disconnects the phone function for both calls and texts, navigation through Waze, etc. Have Samsung Galaxy S9+.

Attaching a few pictures to illustrate problem: 1) 3rd tile shows phone disconnected for some reason for phone functions, which makes all the important features (texting, Waze, etc) unusable. 2) 4th tile shows Android Auto connecting to car and displaying phone though. Not sure why phone functions are not working. Hope this is an easy fix! Thanks!

Try different cables. I have an S8 and I have found that even nice non-samsung cables produce the disconnected issue regularly with my two fords. See if you get the same result with the cable that came with your S9
 

Trending Posts

Forum statistics

Threads
942,827
Messages
6,916,077
Members
3,158,671
Latest member
DonnieH