Android Wear 2.0 Preview loses connection, please help!

Alexxxxxx

New member
Jan 25, 2017
1
0
0
Visit site
I hope someone can help me with a problem I'm having with my iphone 6+ / Huawei Watch...
Today I just noticed there was an update for the iOS Android Wear App which allows you to connect to watches with the new Android Wear 2.0 Preview installed. So i went ahead and flashed my Huawei watch to 2.0 preview and I'm not sure what is going wrong but the initial pairing with my iPhone 6 Plus showed that it was connected and the watch screen went black for a second then showed 'updating' but once it's finished, I immediately lose connection. Now it keeps asking me to reconnect but endlessly searches without ever connecting. I've tried going through the watch settings and even unpaired and factory reset my watch 3 times with the same result... I pair the iphone, it shows connected on the Android App of my phone, my watch shows updating and goes through the usual boot up screen then loses connection and wont connect again. I've even tried to reinstall the app on my phone.
Is anyone having the same problem? Any help will be greatly appreciated.
Thanks much!
Al