Any way to remove Samsung FrP?


New member
Jan 28, 2017
Visit site
Now i don't pretend to know everything there is to know about Android/Smartphones i am rather an amateur.

Hello and welcome to what has been my hell for a week now. Let me introduce you to my problem first because this can be confusing. I purchased a Samsung Galaxy sm-g900p (Sprint) on android 6.0.1 having done all the update. The phone was stock from A to Z. No custom rom, no custom recovery, locked bootloader etc. My problem started when i wanted to root my phone, i had already add a samsung account to my phone and checked "Reactivation Lock" in case my phone gets stolen or lost. I had tried to use cf-root file for my model of S5 and i got an error, i can't quite remember what the error was but basically googled it and it was due supposedly because of the "Reactivation Lock" being on in my settings. So therefore i went to disable it. The phone would back me up to the previous page upon entering my password, now my first though was "maybe i don't have the right password". Which for me is not surprising since i'm using so many password for so many accounts. So i got to reset my password, same thing happened. Now i wanted to "Factory Reset" my phone so the lock goes away. (Like i said, i didn't know much about what would happen etc) To factory reset my phone it did ask for my password and it wouldn't work, it would do the same thing, back me up to the previous page. Now, i knew about "Hard Reset & Forced Factory Reset" and how to do it. So i figured, this would wipe 110% of this phone including the stupid lock bug. Now you guessed it, i was stuck on a welcome page where it says something about an abnormal factory reset. Now i didn't panic yet, i selected my language, entered my wi-fi & the third page was "Samsung Account" page (Not a Google page which i've seen everyone have). My model uses Samsung account to activate back sadly. I tried entering my email and password and guess what, i got backed up to the previous page. Now i was VERY annoyed at samsung for this bug that has caused me to lose my phone basically. Now i know that in life, there's a way to everything, you just have to find it, at least that's my logic. Now using this same logic of mine, i thought logically that if i delete my samsung account, the phone, which is connected to wifi, would have nothing to lock me on, if there is no account. Right? Nope i was wrong, i delete my Samsung Account and i was stuck with a locked phone on an un-exsisting account. Long story short (kinda), after a week of headache and not doing anything else beside trying to get my phone back, flashing roms trying to learn more about "FRP" how to bypass, watch every youtube video ever made about this, contacting samsung about 7 times, talking to some paki in i don't know where. It seems like no one knew ANYTHING about phones and they seemed to only read a damn book and read these "solution" to me. Yesterday i came across a topic on XDA Forum about a bypass for the G900V (Which isn't my version the G900p) i decided to try it out, what harm can be done now? It's to it's worst. In a few words, i got to install a "signed" custom rom where i got to install root and "flashfire" i think it was. I flashed my rom (sprint stock original rom) to my phon from Flashfire apk. I was finally into my phone. Tears of joys down my eyes haha, now i thought this is it, i got my phone back. The thing is, when i flashed the rom (the custom rom) i assume it flashed the "Gapps" too since i was bombarded with "process has stopped" form google services. I had access to my hole phone beside google apps excluding google+ & youtube. Google play wasn't working which is where i have ALL my paid apps & games. I figured i'd try to flash the Gapp back with the right version and voila. Now it isn't as simple as i thought since my phone was still Factory Reset Lock. Which prevented me from flashing the zip, the phone wasn't rooted with my stock rom anymore so i can't flash anything from the phone nor can i with odin. Now i tried removing the FRP in the settings, i would tap "add account" in setting-account-add account and i selected Samsung Account. Whatever i would do, it would not add my account and the FRP was still green checked and greyed out. I told to myself, maybe if i factory reset normally from the setting menu, it would de-activate the FRP. It did ask me for my samsung account so i took a guess and entered it, it worked, my account was now added to the phone, but it did back me up to the previous page (same bug, always the same). Now when i got into Security the "Reactivation Lock" is not greyed out anymore, i tried to uncheck it, entered my password, and i got backed out to previous page. So my situation now is, i have my account in the phone, i received an email saying my phone now belong to my email.

If anyone understood anything about my problem. Please dear god i need help.

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Moved from the Marshmallow forum to the S5 forum, since this is more of a Samsung-specific issue.

Trending Posts

Forum statistics

Latest member