App download issue


New member
Mar 18, 2014
Visit site
I don't know if this is the right forum to ask in (hope so!).

I am trying to download "London Travel" (com.javed.londontravel) from the Play Store/Market. I have the old version v4.2 and there's a new version v5.3 and v5.4 available. v4.2 was 16MB and v5.4 is about 17MB.

When I download it - and I've tried on multiple phones - I get 17MB shown as downloading in the store app, it installs, then can't launch as "no app exists to launch it", and a quick exploration shows the apk on my phone is only about 1 or 2 MB. I've tried using apps like Titanium to back up app+data+cache for it, in case it has other data outside the apk somehow, but Titanium backed up 2 MB as well. I have tried this on a Samsung Ace running stock Gingerbread, and a new Motorola running Kitkat (rooted + Cyanogenmod 11), same result. I even got the same result when I tried using Evozi's online "apk downloader" from my desktop, to test if it was something about the mobile devices or my Google apps.

It's a free app, but I can't seem to download it as a complete working app, yet reviews don't show other people with the same issue. It doesn't seem to be downloadable anywhere except the Market/Play store so I can't even grab it off the author's download site. Any help would be really appreciated?


Retired Moderator
May 23, 2010
Visit site
I would suggest contacting the developer and see if there is a fix for you. I took a quick look through the Play Store reviews and didn't see anything similar to the problem you are having.

Forum statistics

Latest member