Apps not updateing or installing

racermech

Well-known member
Nov 16, 2009
134
2
0
Visit site
I saw an update for Yelp the other day and let it do the update, only to see it failed to install. It did the same thing with Shop Savy. Now today I wanted to install a new game, and it also failed on install.

I am running stock 2.2, have almost 14GB free on my SD, and about 66mb free on the phone. Factory reset is the last option I want to do right now.
 

RUSH

Well-known member
Dec 6, 2010
4,120
285
0
Visit site
... Your network connection should have been able to installed anyone of those apps. Updating data profile should refresh your data network.
 
Last edited:

anon(174838)

Active member
Feb 16, 2011
36
0
0
Visit site
You could also try clearing the market cache/data as that has solved issues for me in the past

Goto manage applications - all - find market in the list, then on the app detail page click wipe data

Then when you open the market again you have to accept the terms again

Sent from my OG Droid (Project Elite 5.0.2) using TapaTalk
 

scarryman04

Well-known member
Jan 15, 2011
829
45
0
Visit site
I've been having this problem lately too, rooted running gingerbread, but I just click on them and download them or update them a second time with no problem.
 

knupug

New member
Aug 20, 2010
1
0
0
Visit site
Here's the solution that worked for me. Found it by googling the problem and found it in the HTC Evo Forum.

Hallelujah! Success at last! The solution for the update problem and at least some of the installation problems (like angry birds rio) is as follows:

First, hook your phone to a computer with a usb cable - need to have your phone in "disk drive" mode. Most likely your phone will at first say "charging only." you will have to click on this to pull up a screen that allows you to change it to "mount as disk drive." Note: this may take several attempts. If your computer does not recognize the phone as being hooked-up at first, unplug it and try again.

Now, open the new drive that will appear on your computer (which, of course, is actually your phone's sd card).

Next, locate the file folders named ".android_secure" (it should be near the top of the listings).

Click on and open up this ". android_secure " folder and look for a file named "smdl2tmp1.asec"

Delete it! Destroy it! Kick it out of your life! It's what is causing the problems!

Unplug your phone. Phone will say something like "preparing sd card." It could take a bit but after that you can update all the apps including those on your sd card and angry birds and download Rio hassle free.

As there a a whole bunch of threads on this issue, please pass the fix on.

Sent from my Evo - so there!
 

Certain

Member
Apr 10, 2010
8
0
0
Visit site
Here's the solution that worked for me. Found it by googling the problem and found it in the HTC Evo Forum.
This worked for me. This problem happened to me a while back and I remember the advice was to remove the android_secure folder or clean it out, I can't quite remember exactly which of those it was, but it worked. Eventually the no install problem started happening again, but only with some apps. All the other tips in this thread....I'd tried those but none of them worked. I tried this one today, and deleted that file and all my apps are installing again.

Now that I think back on it, the advice that I received a while back probably was doing the same thing, they just didn't know it and so they cleared the whole folder instead of that one file.
 

Forum statistics

Threads
942,989
Messages
6,916,766
Members
3,158,763
Latest member
zif835