atrix died

OiZO

New member
Feb 19, 2011
4
1
0
Visit site
So i bought the atrix this morning at 9am at my local att. I have barely touched it just installed some random apps you know angry birds and what not. I had it sitting out on the counter i went over to check the time and it the screen wont come on. I removed the battery still wont go on. I plugged it in let it sit for 2hrs still wont go on. The i removed the battery again and still no go. All the while the little green led indicator keeps flashing at me.

Anyone else having issues like this? After dinner im going to go back to att and hope they still have an extra one they havent sold yet to switch out.
 

sw33ndawg

Well-known member
Feb 5, 2011
160
15
0
Visit site
So i bought the atrix this morning at 9am at my local att. I have barely touched it just installed some random apps you know angry birds and what not. I had it sitting out on the counter i went over to check the time and it the screen wont come on. I removed the battery still wont go on. I plugged it in let it sit for 2hrs still wont go on. The i removed the battery again and still no go. All the while the little green led indicator keeps flashing at me.

Anyone else having issues like this? After dinner im going to go back to att and hope they still have an extra one they havent sold yet to switch out.

sounds like you got a defective phone.
 

anon(153966)

Distinguished
Feb 1, 2011
1,496
49
0
Visit site
...try some sort of hard reset. Normally, you'd have to hold the power button and the home button, then release the power button, while still holding the home button.

Not sure if it'd work on this model or not. But...
 

wulffg

New member
Dec 7, 2010
2
0
0
Visit site
Same here

Picked it up this evening and the same things happening to mine. I was so excited to get rid of my iPhone too...
 

carotene

Member
Feb 24, 2011
9
0
0
Visit site
died too

Mine up and quit on me last night. After an hour long session of browsing the web, the atrix just went dead. The startup motorola logo popped up and then it just went blank.

Removed the battery, no dice. I let it sit on charge all morning but it just sits there blinking the green LED.
Taking it in tonight.

There was a post over on the devs forum with someone with a very similar issue. I'll try a new battery at the store tonight and report back.
 

carotene

Member
Feb 24, 2011
9
0
0
Visit site
Took it by the store tonight. We replaced the battery and it fired right up. Just to be safe, they gave me a new phone too. But it looks like a premature battery failure was the culprit.
 

nory826

Active member
Feb 25, 2011
27
0
0
Visit site
atrix 4g

Same thing happened to me last night. I got my atrix on monday,and after it was activated it started to reboot at random about six different times. Then last night I was watching a youtube video and it did it again for the last time. Started to reboot then went to a black screen with the red led blinking. Pulled battery,nothing worked. I couldnt believe only two days old and it died lol its cool though.went to att and the gave me a new one with no problem. Hope it doesn't happen again...:-!
 

OiZO

New member
Feb 19, 2011
4
1
0
Visit site
Seems like they have a large batch of faulty batteries. Since i did the swap i have had no issues other then a couple of random lock ups that were easily fixed by pressing the power button.
 

sk8trix

Well-known member
Mar 21, 2011
410
20
0
Visit site
that sux mine is one of the first ones but its a trooper its kicking still and working even better after I flashed it and installed GB