ATT G6 Play won't show incoming calls on screen

udazavlanje

Well-known member
Sep 23, 2012
303
0
0
Visit site
From the day one I had Nova Launcher installed and ex-dialer. Just like I had it set up on his old g5s unlocked model. It's just easier to keep the stuff (hide apps) away from a 70yr old who is not tech savvy :) on top I choose even more for him. Basically he can see and use 3 apps...
Weeks later, I hear that this basic phone function, never really worked for my dad.
The problem is that unless you drop a notification down you can't see who is calling nor the option to answer or decline the call.
First I thought that by default some permissions.for the dialer app were missing and accessibility as well. After all this is G with Oreo so who knows. I ran through everything and turned on permissions of all sorts with other apps as well and still no results. Then, I figured it has to compatibility issue and uninstalled the ex-dialer. Now the only one in use is original Phone dialer (Moto). Checked all the settings again and problem won't go away. It crossed my mind to clear cache within Phone App and didn't make a difference. I also made sure that Nova has everything in place. And still nothing.
Finally, I removed Nova as default launcher I started using Moto App Launcher. Nicht, Nada , wtf???
I'm at a loss, here.
To clarify, no matter where you are on the screen - watching videos , texting or just staring at the home screen , you can't see the regular incoming call screen (big screen or dropped down from notifications). All you see is a tiny phone ringing in the far top left corner of the notification line. From there, if you swipe down, you can see it with options to answer or decline and caller ID (just like it should be by default if you are doing something on the phone. So, even when the screen is off, phone just rings. Nothing on screen. You have to turn the screen on and then as mentioned above. Swipe down from notification bar ...
Any input, much appreciated.

Thanks
 
Last edited:

udazavlanje

Well-known member
Sep 23, 2012
303
0
0
Visit site
SOLVED
I found the discussion on Lenovo forum. One was a joke suggested by incompetent rep , but another one did it.
Needs not just Cache cleared from the Phone App, but Data as well (wish I did it earlier!)
After clearing both. Just back to home screen, open Phone - Dialer , (just in case I dialed a number :) and back to home screen.
Called it and all was good. In both scenarios - while in use and with screen off.
What a hassle.
Hope , this helps some people.