bad battery or bad micro-usb port?

preppystud

Well-known member
Jan 10, 2013
461
0
0
Visit site
i have a nexus 7.

recently, i can't charge it like it used to do. i tried all kinds of chargers, only one works. otherwise, even if it is plugged in, the battery will still decrease until it shuts itself off.

i also have to use a voltage monitor, i will have to plug and unplug micro-usb cable several times, before the monitor shows 1.9 v without decreasing to 0 v in less than 1 minute.

rarely, i can plug it in, and the monitor will show about 3.2 v, and charges the tablet until it is full.

--
when i put it in airport mode, the battery doesn't decrease its power quickly. but when i keep the wifi on, it seems that the battery decreases its power quickly.

---

i am guessing that the battery is dying, right? some suggested that it might be because of the bad usb port.
 
Last edited:

Mooncatt

Ambassador
Feb 23, 2011
10,869
491
83
Visit site
You said you tried different chargers, but what about different USB cables themselves? Those are usually what go bad first. If you haven't tried a new cable yet, that would be my first suggestion.

If this still happens with a new cable, then I would suspect the port going out. If it were the battery, it shouldn't be decreasing when plugged in. It may be slow to charge, or not charge to 100%, but not lose power.

Another test you can do is plug it in and try holding the micro-USB plug still in the port while wiggling the cable just behind it. This is the most common failure point of cables and you would get connect/disconnect notices on the phone. If that passes, then try wiggling the plug itself in the port. Connect/disconnect notices during this would indicate a bad port.
 

preppystud

Well-known member
Jan 10, 2013
461
0
0
Visit site
yes i forgot. different chargers and different cables, etc. so i am guessing that it is the battery's problem.

i am thinking about replacing the battery, but i am not 100% sure if that will solve the problem.

one thing kind of puzzled me is that the battery seemed to die all of sudden. i thought that it should slowly disintegrate. all of sudden, it can't be charged when it is on. there was no warning signs.
 

Mooncatt

Ambassador
Feb 23, 2011
10,869
491
83
Visit site
If you've tried known good cables, then I'd lean towards the port being bad. Like I said earlier, it's unlikely a bad battery symptom would be to lose charge while plugged in. If the phone is pretty old, a new battery may be warranted anyway, but I wouldn't expect it to fix this problem.
 

Trending Posts

Forum statistics

Threads
945,714
Messages
6,926,939
Members
3,159,960
Latest member
tuanbinh9990