Basic SMS Outgoing Format

Militass

New member
Aug 30, 2018
2
0
0
Visit site
Hi everyone!

Whenever I send a text message to someone, no matter who it is, I type everything correctly, like ã, é, õ, ç and all the special characters that my language has, and I also send emojis, as everyone else does.

My problem is that the receiver only receives normal letters without the special characters, a capital Ç and blank spaces instead of the emojis I've sent.

I've also had a popup message show up on Messages saying "to support a message from your carrier, the message needs to be converted" (or similar) and it makes you tap Yes or the message won't be sent.

This has me believing that for some reason, my Pixel "turned on an option" that only lets me send SMS in the most basic format possible, like it used to be back in the day, before SMS evolved to supporting emojis and all that. The only way I can send "emojis" is if I type ": - )" instead of choosing an actual emoji.

I've been in touch with my carrier (Vodafone) and they said there's nothing wrong with my SIM and that the problem should be on the phone, with a reasonable doubt.

Has anyone around here experienced a similar issue? I've tried everything I can remember, including a Factory Reset but nothing did the trick.

Best Regards and sorry for the long post!
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
Someone (and I doubt that it's the phone - my Pixel 2, using Android Messages isn't causing a problem) isn't supporting unicode. (I suspect it's the carrier on one end or the other, but I can't see why that would happen in 2018.)
 

Militass

New member
Aug 30, 2018
2
0
0
Visit site
Someone (and I doubt that it's the phone - my Pixel 2, using Android Messages isn't causing a problem) isn't supporting unicode. (I suspect it's the carrier on one end or the other, but I can't see why that would happen in 2018.)

I think so too, the only option that could influence this situation is the one that reads "use simple characters" and that one is already turned off, not changing this situation.

I've been in touch with my carrier and they said that the SIM is fine. Do you think that should ask for another one, just to be sure?
 

Forum statistics

Threads
943,787
Messages
6,920,057
Members
3,159,231
Latest member
seroo