battery connects and disconnects showing a red X on battery.

Uzair Munaf

New member
Feb 28, 2016
1
0
0
Visit site
Since last 2 weeks I have been experiencing the problem. Galaxy S3 on kitkat is not taking charge at all. When I connect to the charger, it charges for a few second, then automatically disconnects and then again connects showing a red x on the battery. The charge keeps on getting less instead of increasing. Again I pull out and push the charger, it again charges for few seconds and the disconnects and then connects showing a red x. I tried removing the battery and re-inserting it, switching of the mobile phone while charging, nothing helped out.*i tried changing the battery it didnt work. I used multiple cables and sockets, it didnt work either.

I am sure there's absolutely no problem in the charger because I have one Galaxy s4 and another s3 at my home, they get charged in the same charger perfectly. I tried charging my S3 through their chargers, I got the same result.*

I tried to charge it through my laptop's USB port, its the same. Nothing is working out. It also frequently switches on the screen, opens the S-Voice and closes it immediately, opens the desk organiser and closes immediately, and it keeps on happening non-stop.*
Any solution?

Posted via the Android Central App
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,500
4,640
113
Visit site
Welcome to Android Central! When you say you changed the battery, did you try a new battery and make sure it was charged up before powering the phone on?

If you did try a new battery and the problem continues, then it might be an issue with the microUSB port. Use a can of compressed air to blow it out, in case there's any debris in there. If it looks clean and the pin looks undamaged, then you may have to bring the phone to a repair shop to see if the port needs replacement, or if the motherboard itself might be failing.
 

Forum statistics

Threads
942,851
Messages
6,916,222
Members
3,158,697
Latest member
aDAMANT007