Battery isn't working properly anymore? Help!

armymelon

New member
Mar 25, 2014
3
0
0
Visit site
About 2 weeks ago I went to my car with 100% or so on my battery and by the time I got to the the car it had drained to roughly 50%. So 50% gone in 10 minutes. That was just the beginning of the issues now my battery won't charge up past 65% if I'm lucky and it will disharge just as fast. I seem to be constantly plugged in to a wall. If anyone has any idea about what to do that would be great!

Posted via Android Central App
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
First - turn the phone off completely and connect the charger. It should fully charge in just over two hours - if it doesn't, there's either something wrong with the charger, the cable, the battery (most likely) or the phone.
Second - not that you can really do anything about it, but the Mobile network signal in the History details looks rather marginal. Nothing will run down a battery faster than the radios constantly trying to maintain a connection.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

AxlMyk

Well-known member
Sep 12, 2012
1,217
0
0
Visit site
How old is the battery? Mine was 1.5 years old and I just replaced it. I'm using a RAVpower 2250mah unit that leaves me with 30% at the end of the day. That's with a lot of daily use. So far I'm very happy with it.
 

armymelon

New member
Mar 25, 2014
3
0
0
Visit site
Thanks for thr responses guys! It's been like this for two or so weeks so I ordered a battery online, I'll look into that RAVpower battery though thanks for the advice! Last night I charged for 12 hours while the phone was off and it only went from 1% to 9% so something isn't right for sure..

Posted via Android Central App
 

Trending Posts

Forum statistics

Threads
944,524
Messages
6,923,193
Members
3,159,606
Latest member
JaysonIrwin