Battery Meter Gone Haywire

enb123

Well-known member
Mar 25, 2011
93
1
0
Visit site
Uh oh.

When I came home today, my N6 was at about 30%, so I put it on the charger and came back after a couple of hours to a warning that the phone was at 2% battery. I unplugged it, and the meter went to 100% right away, so I shrugged it off as a glitch.

I used the phone normally until this evening, and the battery dropped to 15% over time, as expected. I plugged it in and the meter read "100%" right away. I went to Battery Settings, and it also said I was at 100%, with about 15 minutes remaining or something like that.

I rebooted - same problem. I plugged the phone in with the power off, and the battery icon in the center of the screen was also full. That worries me.

I've had the phone since December, and it's been fine until this. The battery doesn't appear to be swollen or anything - I haven't pried off the back, but it's not puffy.

I'm doing a factory reset now - yuck! - but I was curious as to whether anyone else has had this problem and what you think?
 

kct1975

Well-known member
Jul 1, 2013
705
7
18
Visit site
It sounds like a battery calibration issue to me.

Right now I don't remember the procedures for recalibrating the battery, but I am sure that you can Google it, and get plenty of results.

If I can remember the procedures, or find them, I will post it.
 

enb123

Well-known member
Mar 25, 2011
93
1
0
Visit site
Thanks - I'll look. The factory reset didn't do anything to fix it, btw. I'll post a follow up if I can find the recalibration procedures and if they work!

BTW - if you do find something, could you please post again? Just in case I don't find the right procedures.
 

SteveMW

Well-known member
Mar 31, 2011
62
4
0
Visit site
Had a similar problem with my N7 (2013). Had it for a few days short of one year and suddenly after removing it from the charger the battery ap remained at 100% with no app have for a day. Rebooting the device had no effect, still read 100% and no apps. The problem corrected itself. Was the strangest thing I have witnessed with any mobile device.
 

enb123

Well-known member
Mar 25, 2011
93
1
0
Visit site
It's odd - battery doesn't seem to be draining any more quickly than usual, but the battery settings graph shows like 2 hours remaining on a charge.

I can't tell yet what the disconnect is. If it's really at 100%, then the estimated time remaining can't be right. On the other hand, if the time remaining is really 2 hours, then the battery either didn't fully charge or it suddenly lost a ton of its useful life.

Factory reset didn't seem to do anything, BTW, although I guess nuking everything once in a while is good.

We'll see!

Edit: after spending an hour or two on standby, projected battery life has gone to 13 hrs, so maybe it's OK again?

Sent from my Nexus 6 using Tapatalk
 
Last edited:

Forum statistics

Threads
945,126
Messages
6,924,301
Members
3,159,673
Latest member
netabb