Bell Galaxy S3 just.. died.

Go Easy Jerk

New member
Aug 19, 2013
3
0
0
Visit site
New to the forums but I've lurked for a while, I've been having a problem with my S3 and can't seem to find an answer on any of the threads I've browsed.

My Galaxy S3 was working fine, then I tried to unlock the home screen and nothing happened. I figured the battery may have died, so I pressedthe power button and nothing happened, I then tried a longer press and again nothing happened, I then tried to do the factory reset thing where I held the volume, power, and home screen buttons all at once and again nothing happened.

I got home and plugged it into the wall charger and there was no red charging light, I took the battery out and plugged it in and there was a red light but phone wouldn't power on. I put the battery back in and the charging light went back off.

If anyone has a clue as to what this might be your input would be appreciated.

Cheers
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,380
126
63
Visit site
New to the forums but I've lurked for a while, I've been having a problem with my S3 and can't seem to find an answer on any of the threads I've browsed.

My Galaxy S3 was working fine, then I tried to unlock the home screen and nothing happened. I figured the battery may have died, so I pressedthe power button and nothing happened, I then tried a longer press and again nothing happened, I then tried to do the factory reset thing where I held the volume, power, and home screen buttons all at once and again nothing happened.

I got home and plugged it into the wall charger and there was no red charging light, I took the battery out and plugged it in and there was a red light but phone wouldn't power on. I put the battery back in and the charging light went back off.

If anyone has a clue as to what this might be your input would be appreciated.

Cheers

I see you posted in another section of the forums. Have you recieved an answer yet?
 

JoeLouie

Member
Dec 3, 2011
5
0
0
Visit site
I had the exact same thing happen to me about 6 months back with my Telus S3. I had just finished a call and hung up and the phone shut off, so I tried to turn it back on and nothing. I got a red light if I plugged it in, but that was as much as I could get. The computer wouldn't recognize it either.

I ended up having to have it sent out for repairs. I forget exactly what it was that they had to replace, but it definitely required a repair. Luckily for me I only had the phone for a few months at that point so the repairs were under warranty. Hopefully you'll be as lucky.