[Bluboo Xtouch] My phone wont turn on or charge. Can you help me?

A

AC Question

Hello
I have a Bluboo Xtouch running the stock firmware (5.1.1), the CPU is an octa-core MediaTek 6753, bootloader unlocked and honestly, don't really know if it's rooted or not. The battery is not removable.

My problems started a week ago, when I decided to do a factory reset to my phone. I made a backup of my important things and decided to remove the root to make a truly factory reset. After the reset, I installed some apps and decided to root my phone again. As my phone is a MediaTek processor, it needs to flash the zip file of SuperSU, as shown on XDA Developers.

I turned of my phone, turned on in recovery mode, flashed the zip file and selected the reboot option. However, the phone didn't reboot, it just turned off. Then, I tried to turn on normally, turn on in recovery, charge, turn on while charging, with no success.

So I thought "I'm sure the problem is not hardware. So it can only be the OS. Since I've reseted the phone, I can format and reinstall the OS.". Then I searched the drivers and downloaded the OS and SP Flash Tool. Followed the guide, did all things correctly and the program didn't show any problem. But when I tried to turn on, nothing happened, then turned on in recovery, charged, turned on while charging, nothing to.

Here is my problem, although the program didn't show any problems, I can't turn on my phone. I've been looking for the resolution of my problem on many sites but I've not found anyone with this problem in specific. The difference is that I'm sure the phone has the OS in there and it's the original.

Could you please help me with any solution that you might have?
Thank you for your attention.
 
D

Deleted member 2968739

Hello again
I really need your help, I'm desperate, really desperate. I think I've done everything I could and I can't remember more to do. Don't know if this will help but I've made a readback test with SP Flash Tool and no error, then I've made a memory test and this was the result:
=========== Memory Detection Report =========== Internal RAM: External RAM: Type = DRAM Size = 0xc0000000 (3072MB/24576Mb) NAND Flash: ERROR: NAND Flash was not detected! EMMC: EMMC_PART_BOOT1 Size = 0x0000000000400000(4MB) EMMC_PART_BOOT2 Size = 0x0000000000400000(4MB) EMMC_PART_RPMB Size = 0x0000000000400000(4MB) EMMC_PART_GP1 Size = 0x0000000000000000(0MB) EMMC_PART_GP2 Size = 0x0000000000000000(0MB) EMMC_PART_GP3 Size = 0x0000000000000000(0MB) EMMC_PART_GP4 Size = 0x0000000000000000(0MB) EMMC_PART_USER Size = 0x0000000747c00000(29820MB) UFS: ERROR: UFS was not detected! ============ RAM Test ============ Data Bus Test: [D0
[D1] [D2] [D3] [D4] [D5] [D6] [D7] [D8] [D9] [D10] [D11] [D12] [D13] [D14] [D15] [D16] [D17] [D18] [D19] [D20] [D21] [D22] [D23] [D24] [D25] [D26] [D27] [D28] [D29] [D30] [D31] OK!! Address Bus Test: [A1] [A2] [A3] [A4] [A5] [A6] [A7] [A8] [A9] [A10] [A11] [A12] [A13] [A14] [A15] [A16] [A17] [A18] [A19] [A20] [A21] [A22] [A23] [A24] [A25] [A26] [A27] [A28] [A29] [A30] [A31] OK!! RAM Pattern Test : Writing ... 0x44332211, 0xA5A5A5A5, 0xA5A5A500, 0xA500A500, 0xA5000000, 0x00000000, 0xFFFF0000, 0xFFFFFFFF, OK!! Increment/Decrement Test: Writing... OK!!]

PLEASE, PLEASE, I need somebody's help!

P.S.: I am the same person that posted the message above.