blurry video camera after 2.2

antmon1

Well-known member
Jun 17, 2010
83
3
0
Visit site
anyone noticed how poorly the video recording quality is after your update to 2.2? unless you are outdoors with full sunlight, the cam takes horrible videos...especially if you pan around...

thought it was a prob with how you went from 2.1 to 2.2, but apparently it doesn't matter...

the firmware setting option hasn't worked for me, but assuming it will have some future use...


lots of info here too:

video camera blurry? - Page 7 - xda-developers
 

robyn25

Well-known member
Oct 7, 2010
106
5
0
Visit site
Yes, I compared a video before 2.2 to one after and it was insanely different. I want the better quality back now!!!! Any help would be appreciated!!! This was one of the best and most impressive features of the phone, I hate to lose it!
 

fbcregan

Active member
Jan 7, 2011
32
0
0
Visit site
Mine was doing that too after the update, but I unmounted and remounted the SD card and it's much better. I don't know if it's as good as Eclair, since it's been awhile since I used that, but no major motion blur anymore.

UPDATE: I take that back. It is just better with more light. I tried it under my desk and the blur is just as bad as before. HD video recording is one of the main reasons I chose this over the Evo. Everyone said the Epic took way better video. This is unusable.
 

antmon1

Well-known member
Jun 17, 2010
83
3
0
Visit site
i removed everything from the sd card, reformatted it and then tried to take vids with an empty card...still no dice...

the video recording is hosed...well, the camera overall is a mess (see other posts on sport mode crashing it)...

all those delays in putting out 2.2 and they touched something that worked just fine in 2.1....

the folks at samsung/sprint are a weird bunch...
 

Mobius360

Well-known member
Aug 26, 2010
649
25
0
Visit site
It's a sad thing no doubt, I experienced the sport mode crash with DK28 froyo which was out for months. It boggles my mind Sprint would not release DK28, they wait and wait, tell us they are fixing things, EB13 comes out and from what I can tell is just about the exact same experience but with a few features from DK28 missing. I just don't get it.

Hopefully the camera can be fixed through the new firmware update option it has. I doubt it will be addressed when they re-release froyo which I imagine will happen rather quickly after yet another Samsung debacle updating their Galaxy S line to froyo. You had the canadian phone issues, then the kies nightmare a couple weeks ago, our issues and probably another kies nightmare today (people with macs can't even use kies). To go along with the Sprint upgrade path, they make it confusing for the average person, if you manually update. If you have a mac you would download the mac version, and pc the pc version, how many people would know they could use the mac version and it would not wipe the data off their phone.
 

IZZY Dead

Well-known member
Oct 20, 2010
61
10
0
Visit site
I hate to be a whiner but this could be a deal breaker for me and Sprint. I also purchased this phone over the Evo because of the camera quality and it now has taken a major dump. If there are any hacker's out there who know how to extract the old apk, edit the current one all input is welcome.
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
I hate to be a whiner but this could be a deal breaker for me and Sprint. I also purchased this phone over the Evo because of the camera quality and it now has taken a major dump. If there are any hacker's out there who know how to extract the old apk, edit the current one all input is welcome.

This is a bug in Froyo. There are 2 new kernels available to those who have rooted their phones. It addresses the camera "sport" mode fc and also the slow framerate I believe.

More information go below.

Kernels
 
  • Like
Reactions: IZZY Dead

antmon1

Well-known member
Jun 17, 2010
83
3
0
Visit site
wow, this is great....thanks for the link...

have never installed a kernal, but I am rooted so will look into this.... I think you just reboot with that zip file (kernal) on the root of the sd card and that will only overwrite the camera app...but not 100% sure yet...
 

Tech_Hunter

Well-known member
Nov 2, 2010
49
3
0
Visit site
Izzy

Could you explain how to apply the patch? Try as I might I cant find any specific instructions.

Thank you!

Explained in post #36 of the linked thread. No need to be rooted.

Personally, I chose instead to flash the genocide 0.3a kernel found on XDA, which includes this fix, provides better battery life at stock speed, and provides an option for overclocking. Root is required.
 
  • Like
Reactions: bigtimeweb

IZZY Dead

Well-known member
Oct 20, 2010
61
10
0
Visit site
First and foremost you take full responsibility for doing this:
1ST: download these 2 files:http://www.club.cc.cmu.edu/~mkasick/android/epic_camera_fix-EB13.tar
and this file in case you need to odin back to completely stock kernel:http://www.club.cc.cmu.edu/~mkasick/android/epic_stock-EB13.tar
2ND: Watch this video on how to use odin:
YouTube - SAMSUNG EPIC 4G HOW TO ODIN TO STOCK FROYO 2.2 DK28 AND ONE CLICK ROOT
You are going to put the previously downloaded camera fix .tar file in the PDA position exactly like he did.
Download usb drivers here under software/usb driver:
Samsung
Download odin here:
http://www.sdx-downloads.com/devs/noobnl/Odin3+v1.61andepic.pit.zip
3rd: Open up Odin and put your phone into “download mode”
◦Turn off your phone, wait until the lights turn off
◦Hold “1″ on the keyboard while powering up
4TH: Plug your device in
5TH: Place the .tar file in the PDA slot
6TH: Start flashing
7TH and last best of luck in your Flashing endeavors.
The other .tar file is for flashing back to completely stock kernel for updates as you may not receive them because this is essentially a custom kernel.

I know my instructions may be vague. If you are not comfortable doing this, please research it more till you are.
After I did this yesterday I rooted my Epic so i could also fix the Horizontal/Vertical rotation lag. I used the 1-click method as noted here on Android central.And then after downloading Terminal Emulater and Ran:/system/bin/sensorcalibutil_yamaha

After the manual update of 2.2, I refuse to downgrade to 2.1 to fix these issues and refuse to wait on Samsung and Sprint any longer when all of your issues can usually be resolved right here on android central and XDA in a matter of days, if not hours.
 
Last edited:
  • Like
Reactions: bigtimeweb

bigtimeweb

Well-known member
Feb 25, 2011
58
9
0
Visit site
Thanks for the follow up post, Izzy

Ive actually been at it since you first posted. Unfortunately Odin just hangs. Initially it was at Get pit for mapping now its almost constantly at Initializing....just sitting.

Im on Win7 64bit so I alt clicked the file tried to run in WinXP compatible mode. Same result. Dragged an old XP installed HD out of closet, transferred files over to it...same result.

That's when I saw you had re-posted with links but of course I couldn't see your links because I wasn't logged in and PW is on WIN7 drive, so swap to different boot, redownloaded Odin from your link...Watched Youtube video - this guy is on WIN7 and isn't messing with compatibility mode so gave it a whirl again....again just hung at Initialization. Okay lets try Win XP Compatibility and run as admin...hangs at Setup Connection. Unplug start again...hung at Initialization again.

Im frustrated....and bricked I guess cause now I turn on my phone and its just a small phone icon dot dot exclamation dot dot pc icon.
 

IZZY Dead

Well-known member
Oct 20, 2010
61
10
0
Visit site
It hung on me the first time but i switched usb ports and it initialized.
check to see in device manager that it it seeing your phone when you plug it in. Also run odin as Administrator.

Is your phone stock eb13, Are you unchecking "F Reset time" and are you selecting camerafix.tar from the PDA button?

Plus nothing will should happen to your phone unless hit start, and you should be initialized first before you hit start

Do you have a 32bit machine to try this on? And each time are you fully shuting down odin and making sure it isn't running in task mngr.
Plus you should not select a PIT file.
 
Last edited:

sammmmmyg

Member
Dec 9, 2010
18
0
0
Visit site
I just flashed w/ the camera fixed and am no longer having the camera issues. It's amazing to me that Samsung/Sprint could get this so wrong. Especially when you consider the cause of the problem. What were they doing for two months after the DK28 leak? As much as I like some things about my Epic, I think this will be my last Samsung phone product.
 

bigtimeweb

Well-known member
Feb 25, 2011
58
9
0
Visit site
First, apologies to you mis13 - I didnt realize that was you pointing me to that post.

Thank you for trying to help.

Ive tried on 64 bit and repeatedly on 32 bit. I have 6 rear USB ports and two top front. Device keeps not wanting to recognize randomly.... When it recognizes I have a SAMSUNG modem entry and a SAMSUNG USB entry in device manager. I have that now.

Yes to all your questions:
Stock no rooting did manual eb13 update.zip update.
F Reset time not checked
fix tar selected and I haven't even d/l'd the revert tar as of yet, so no confusion there
No pit file selected
Running ODIN as admin - easy on win7 bit weird on XP, but the user Im on in XP is admin - not using the hidden admin

Im back on 64bit now, using yet a different USB port, device recognized, F Reset Time not selected, fix tar in PDA selected, device seen on COM10, hit start - whooo we moved to zimage! But that was 10min ago and its still sitting there....

/le sigh


Edit for update rather than new post:
I just left it running and walked away and it finally took! Started at zImage at 4:25p cst and fished at 5:53p cst - GAH!!!!!

So it roboots and now its stuck on the bootscreen that says SAMSUNG. Permanently.
 
Last edited:

Butters3605

Well-known member
Nov 3, 2010
111
9
0
Visit site
Thanks for the follow up post, Izzy

Ive actually been at it since you first posted. Unfortunately Odin just hangs. Initially it was at Get pit for mapping now its almost constantly at Initializing....just sitting.

Im on Win7 64bit so I alt clicked the file tried to run in WinXP compatible mode. Same result. Dragged an old XP installed HD out of closet, transferred files over to it...same result.

That's when I saw you had re-posted with links but of course I couldn't see your links because I wasn't logged in and PW is on WIN7 drive, so swap to different boot, redownloaded Odin from your link...Watched Youtube video - this guy is on WIN7 and isn't messing with compatibility mode so gave it a whirl again....again just hung at Initialization. Okay lets try Win XP Compatibility and run as admin...hangs at Setup Connection. Unplug start again...hung at Initialization again.

Im frustrated....and bricked I guess cause now I turn on my phone and its just a small phone icon dot dot exclamation dot dot pc icon.

I got the small phone icon dot dot exclamation dot dot pc icon and thought I was screwed, but you are not beyond recovery:
  1. pull the battery
  2. boot into download mode (1 + power)
  3. You should get the downloading sreen, recover as normal
http://forum.androidcentral.com/epi...ory-restore-fix-bricked-phone.html#post614683

I had an issue with hanging, I am using Vista x64. I re-download the files to the desktop and added them into odin from there. Also make sure you are using the latest version of odin, I think it is v1.61, and have all the correct drivers installed.

BTW the patch cured my camera issues, a BIG thank you to XDA!!
 

bigtimeweb

Well-known member
Feb 25, 2011
58
9
0
Visit site
Just wanted to follow up and say that it was my stupid USB cord. Soon as I dug through my closet for another cord everything went without a hitch.
 

Trending Posts

Forum statistics

Threads
942,903
Messages
6,916,453
Members
3,158,733
Latest member
Cy3berOdyssey