Question Both Pixel and S22U Fail to Deliver Gmail Notifications

bluebliss7

Member
Sep 6, 2012
22
10
3
Visit site
Hi everyone,

Been years since I've been here!

FWIW, this issue has been brought up a lot and I've tried every fix I've read about for months, but hope to gain some more insight and learn from you.

I have a Pixel 7 on Android 14 and an S22U on Android 12 / One UI 4.1.

Both phones suffer from delayed Gmail app notifications. I have both phones fully charged, all battery optimization features off, all notification categories enabled, etc., yet when they're sitting on a table right next to my iPhone, the iPhone will *immediately* notify me of an incoming email. However, both the S22U and the P7 sit there for minutes, sometimes hours, without ever showing the email notification.

Only when I pick up and start using either phone will they "get" the push notification and show the email.

This drives me crazy as I use both Android phones for work, but have largely tabled them since I can't rely on them being consistent.

What gives? Does anyone have a definitive answer or even a hint/clue as to why this happens? Any new fixes people have discovered and can add to this thread so we can save people the headache for years to come? :)


Thanks!

Edit: I forgot to mention tha the only fix I've ever found was the adb command to disable Doze, which actually worked when I tried it months ago! My Pixel would get emails immediately just like the iPhone; the S22U would quietly sit there. However, this fix wasn't permanent and resets itself after a restart.
 
Last edited:

bluebliss7

Member
Sep 6, 2012
22
10
3
Visit site
Unfortunately, it's a no go. :(

I also tried another suggestion to set the sync time period to "one day" instead of the default 30 days, and still no dice.

It's infuriating that Google doesn't have a fix for this given the number of people complaining about it. @mustang7757 I also noticed that you've been trying to help people through this for years while searching in old threads!
 
  • Like
Reactions: mustang7757

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,576
7,132
113
Visit site
Unfortunately, it's a no go. :(

I also tried another suggestion to set the sync time period to "one day" instead of the default 30 days, and still no dice.

It's infuriating that Google doesn't have a fix for this given the number of people complaining about it. @mustang7757 I also noticed that you've been trying to help people through this for years while searching in old threads!
Yeah through the years I've been trying to help with this issue some we found the solution and others we tried many things with no success and that's for other apps .

Samsung has so many settings to go over for these things.

Make sure your notifications are set for all apps in settings>notifications

Do you use DND?
 
Last edited:
  • Like
Reactions: Laura Knotek

bluebliss7

Member
Sep 6, 2012
22
10
3
Visit site
Yeah through the years I've been trying to help with this issue some we found the solution and others we tried many things with no success and that's for other apps .

Samsung has so many settings to go over for these things.

Make sure your notifications are set for all apps in settings>notifications

Do you use DND?

No DND on either of these phones. Don't forget that there's both a Pixel and a Samsung here, but yes I agree, there are so many darn settings between notifications/battery/etc to check!




Do you have your Gmail set to POP3 or IMAP? IMAP is the better and more modern protocol.

I just checked and the default settings are intact. Looks like POP is disabled, but IMAP is also disabled.
 

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
12,060
4,738
113
Visit site
No DND on either of these phones. Don't forget that there's both a Pixel and a Samsung here, but yes I agree, there are so many darn settings between notifications/battery/etc to check!






I just checked and the default settings are intact. Looks like POP is disabled, but IMAP is also disabled.
Have you tried enabling IMAP? Let us know if that helps.
 
  • Like
Reactions: mustang7757

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,576
7,132
113
Visit site
No DND on either of these phones. Don't forget that there's both a Pixel and a Samsung here, but yes I agree, there are so many darn settings between notifications/battery/etc to check!






I just checked and the default settings are intact. Looks like POP is disabled, but IMAP is also disabled.
Interesting , are you using Gmail from a 3rd party E-mail service app because the stock Gmail don't have option for IMAP or pop3
 
  • Like
Reactions: Laura Knotek

bluebliss7

Member
Sep 6, 2012
22
10
3
Visit site
Have you tried enabling IMAP? Let us know if that helps.

Just enabled that and will report back tonight!


Interesting , are you using Gmail from a 3rd party E-mail service app because the stock Gmail don't have option for IMAP or pop3

All stock apps, Mustang. The options I see are in the web-app version within my desktop browser. Note that this account that has issues is a Google Workspace account (not a personal gmail, but a corporate gmail I have). I don't think that matters but I can cross-check with a personal Gmail account too.

See attached screenshot showing the settings in the Gmail menu.
 

Attachments

  • Screenshot 2024-06-18 at 4.51.45 PM.png
    Screenshot 2024-06-18 at 4.51.45 PM.png
    245.1 KB · Views: 4
  • Like
Reactions: mustang7757

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,576
7,132
113
Visit site
Just enabled that and will report back tonight!




All stock apps, Mustang. The options I see are in the web-app version within my desktop browser. Note that this account that has issues is a Google Workspace account (not a personal gmail, but a corporate gmail I have). I don't think that matters but I can cross-check with a personal Gmail account too.

See attached screenshot showing the settings in the Gmail menu.
Ahh ..work Gmail makes sense now then like Laura mentioned IMAP should work in this case
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,576
7,132
113
Visit site
Update: even after enabling IMAP manually, there's no difference. Same test as before: iPhone gets the email immediately; P7 and S22 sit there without any notifications whatsoever.
I heard these work emails giving an issue but can't remember a fix , you can try logging into it on chrome web browser and see if chrome gives you notifications for it until you find a solution
 
  • Like
Reactions: Laura Knotek

bluebliss7

Member
Sep 6, 2012
22
10
3
Visit site
Update:

After re-trying all of these fixes again last night, I have two different results:

The P7 does not show any email notifications at ALL anymore; not even after I pick up the phone and start using it!😁

The S22U shows emails 10 minutes late, but it consistently gives the notification around that 10-minute mark (which is an improvement, I guess).

Try removing that G suite account from your phone do a restart and add it back again I think it was a fix awhile back if I remember correctly

I've done this multiple times, but don't mind trying again tonight.
 
  • Like
Reactions: mustang7757