Can't copy new music to SD card

xunil76

New member
Aug 5, 2015
3
0
0
Visit site
i have a Samsung Galaxy S4 that was just recently updated to lollipop (5.0.1 on Sprint).

i know about the changes to the SD card write permissions starting with 4.4 KitKat, but i;m not sure if this is related, because was on 4.4.2 before and did not have the issue i am having now.

before (on 4.4.2), i could unmount my SD card and put it into a USB card reader, then copy folders of MP3 files into a folder titled "Music" on the root of the SD card, which then contains folders for the Artists, then the albums under each artist. this was done via windows explorer in W7.

however, now (on 5.0.1) it allows me to copy the folders/files into the "Music" folder, but then when i launch my media player on the phone, the new albums don't appear in the list, even after rebooting the phone and waiting for the SD card to initialize. i take the SD card back out and put it back into my computer via USB card reader, and the folders i added before are no longer there at all.

i have also tried connecting my phone directly to the computer via USB cable, and i can do the same thing....it lets me copy the files onto the SD card, but then those files are not available in the media player, and if i disconnect/reconnect the phone from the USB cable and go back to my "Music" folder, the files/folders i copied there are gone.

this is driving me bonkers trying to figure out, anyone have any ideas on how i can regain this (seemingly) basic functionality?

BTW, i have all the USB drivers installed for my phone under Windows and up to date, so i don't think it's a USB communications issue.
 

Petr Tanker

Well-known member
Oct 5, 2013
55
0
0
Visit site
Format your SD CARD to exFAT or FAT32. Or use another player (I'm using JetAudio). In your media player set your MUSIC folder on extrernal card manually if you can. And LINK2SD could help you too.
 

xunil76

New member
Aug 5, 2015
3
0
0
Visit site
sorry, forgot to mention that....it's already been formatted in exFAT, and has been working fine for almost 2 years with Winamp for Android, with my music folder set to the SD Card...it's only after the upgrade from 4.4.2 to 5.0.1 that this has started occurring. i did also try VLC for Android, and it also has the same issue.