Card problem

Mr Roberto

New member
Jan 5, 2013
Visit site
Hello, I'm new to the forums.
Today I bought a 32 GB MicroSDHC memory card for my at&t s3.
1) I inserted it into my phone and then I tried taking some photos. I set the output path to the card and I took a picture. The picture was successfully saved to the sd card, but when I tried taking a second picture, I received an error: "Cannot write file in SD card. Default storage set to Phone". If I try again to set the memory card as default storage I can again take another photo, but the next one will fail as described again.
2) With SD card mounted to the S3, I plug in the USB to connect it to my computer. I can then see the card and view the files on it. However, I'm unable to write anything on it. (Copying something to the card will freeze my windows explorer)
3) If I insert the card into my computer via adapter, then all works fine. I can write to it fine.

It seems that the problem only occurs when the sd card is used by the S3.

Note: I have checked the card for read-only notches and it has no such thing.
Note2: I have a rooted phone running JB 4.1.1 stock.

Any help will be appreciated. Thank you.