Cell connectivity is just bad or is TMobile just this bad.

TheAngryToaster

Well-known member
Sep 14, 2020
340
41
28
Sitting in my hotel, currently on a work trip. My speeds are 600+ Mbps with TMobile and yet not a single app loads in any reasonable amount of time.

For reference I have stayed in my currently hotel on every work trip and never had this issue with my s22u (unlocked) or my iphone 13 pro.

When connected 2 the hotel wifi with a vpn. Everything loads perfectly and works like normal. I cannot even get this app to load outside of wifi.

I remembering reading about connectivity issues with the Pixel 6 series and well so far this seems to be the case with this series as well.

Edit: After more issues with the device just straight dropping internet completely. It would seem that I may have gotten a device with a hardware issue. The luxury of having a work phone on the same network allows me to rule out network issues. When this phone dropped internet my work phone was just fine. I just guess the Pixel isn't for me at the moment. I am hopeful with googles agressive investment into hardware. We shall see what they actually do with that.

Edit 2: Definitely was the phone not the network. Staying in the same place I was last week with the pixel for work and the fold 4 has zero signal issues. Was going to get a replacement but after 2 hours of run around from Google support. I just opted to return the phone.

Sent from my Pixel 7 Pro using AC Forums mobile app
 
Last edited:

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
10,647
626
113
I'm sorry you're having connectivity problems. Have you asked T-Mobile if they are servicing any towers nearby?

If it's related to the Pixel 7 Pro, I hope you'll be able to take your S22 Ultra or your iPhone 13 the next time you're in this hotel or in this town.
 

pseudoware

Well-known member
Feb 15, 2011
1,259
3
38
I'm on T-Mobile but don't have this issue. Maybe ask them to provision a new sim for you, tell them you got a new Pixel. Worth a try, good luck.
 

bkeaver

Well-known member
Apr 24, 2010
1,165
46
48
I've not had this issue either from the pixel 7p or T-Mobile

Sent from my Pixel 7 Pro using Tapatalk
 

Gdraft#WN

Well-known member
Jul 9, 2012
289
0
16
I had this issue with the Pixel 6. Horrible connectivity.
But the P7 has been flawless so far.

If your on Tmo you might want to turn off 5G. I've found that to be spotty
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
86,708
673
113
I heard the regular 7 has less bands then the 7pro but I'm on TMobile no issues in my area don't travel so can't say elsewhere, but try resetting network see if it helps and turning off adaptive connectivity in setting>connection
 

o4liberty

Well-known member
Dec 9, 2009
2,880
16
38
My T-Mobile cell service can be spotty at times as you describe.

Sent from my SM-S908U using Tapatalk
 

J Dubbs

Well-known member
Jun 4, 2016
3,219
27
48
My T-Mobile cell service can be spotty at times as you describe.

Sent from my SM-S908U using Tapatalk

Yep sometimes it's easy to blame the phone, but it seems like since 5G started being a "thing" cell service with all the carriers has went downhill :-\
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
86,708
673
113
I ended up chatting with TMobile and had them refresh my esim on thier end. Turned off that adaptive setting which I didn't even know was a thing lol. So far things seem to be doing much better!

Sent from my Pixel 7 Pro using AC Forums mobile app
Good to hear, yeah I noticed that settings on my 6pro and helped tremendously with connectivity I still keep it off on my 7pro lol

Sent from my SM-F936U1 using AC Forums mobile app
 

TheAngryToaster

Well-known member
Sep 14, 2020
340
41
28
I think I have a dud or hardware problem. I tried to switch to LTE just to see if that helps. The phone completely dropped connection and went to emergency. Had to restart the phone to get the network back. It will just randomly drop all internet, I have to either restart or turn airplane mode on and off to get the internet back.

This device is going back as soon as I get home from my work trip. Can't really rely on this device to work properly when traveling. Samsung has yet to let me down.

Sent from my Pixel 7 Pro using AC Forums mobile app
 

J Dubbs

Well-known member
Jun 4, 2016
3,219
27
48
I think I have a dud or hardware problem. I tried to switch to LTE just to see if that helps. The phone completely dropped connection and went to emergency. Had to restart the phone to get the network back. It will just randomly drop all internet, I have to either restart or turn airplane mode on and off to get the internet back.

This device is going back as soon as I get home from my work trip. Can't really rely on this device to work properly when traveling. Samsung has yet to let me down.

Sent from my Pixel 7 Pro using AC Forums mobile app

It sounds exactly the same as some 6 Pro's were behaving. I wonder if Samsung is still having quality control issues with their manufacturing? I haven't set my 6 Pro up yet, but I'm hoping since it's from the latest batch of phones it's one of the good ones lol. Sometimes it's fun to throw the dice...
 

Chillywill95

Member
May 6, 2022
18
0
0
Hmm, I may have to see if I can find a TMobile store and get a physical sim and test that out.

Sent from my Pixel 7 Pro using AC Forums mobile app

I'm using a physical sim in T-Mobile and I'm surprised that my data and call connections are so consistent. But, there are always those areas around town where TMobile just has a weak to no signal at all and it drives me nuts. Every time I go to WinCo, I can't stream my music if it's not downloaded to my phone. And, if I'm trying to listen on Bluetooth ear buds, I can't even pause the music because it's cutting in and out so much. And, of course, it really goes berserk when I'm at the check out line right when the clerk wants to talk to me! Grrrr!