Changing MESSAGE CENTER number in Verizon Samsung Galaxy S4

acannon420

Member
Jul 31, 2011
5
0
0
Visit site
I have two Galaxy S4 phones, purchased from Verizon 2 years ago... we're moving our phones to NEW numbers over on T-Mobile's network. T-Mobile sent new SIM cards to go into the Galaxy S4 phones. We've established connection to the T-Mobile network and can make/receive phone calls, we have data connection and can RECEIVE texts, but cannot SEND texts. Support from T-Mobile says that my MESSAGE CENTER number wasn't updated when we installed the new T-Mobile SIM cards. Also, there's no place in SETTINGS in MESSAGING that will allow me to change the MESSAGE CENTER number. T-Mobile has tried sending an over-the-air update which also didn't work. Their next idea is a 2nd set of new SIM cards. They're due to arrive Tuesday afternoon. In the meantime I wanted to check... is there any OTHER way I can manually change the MESSAGE CENTER number?
THANKS SO MUCH in advance! :confused:
 

shel692

Well-known member
May 10, 2011
96
1
0
Visit site
The new sim should automatically update that.... It more sounds like Verizon did not fully release and rebroadcast your numbers. Anyway... go to dialer and enter *#*#4636#*#* and once in the hidden menu settings, select phone. Scroll all the way down and you will see SMSC, it should be blank. Touch update and the new SMSC should be +12063130004 for T-Mo.
 

shel692

Well-known member
May 10, 2011
96
1
0
Visit site
I forgot Sammy was a little different.... try these steps...

1.
Find "Settings"
Press Messaging.
Press the Menu key.
Press Settings.
2.
Save the message centre number
Press Message Centre.
Key in (appropriate smsc) and press OK.
3.
Return to the Home screen
Press the Home key to end the session and return to the Home screen.
 

Trung Tran4

New member
Jul 30, 2015
2
0
0
Visit site
I am having same issues. moved from verizon to t-mobile 2 months ago. MMS works, phone calls works, SMS receive works, but SMS send does not work. (actually checking for systems update always gives "service unavailable").

model: SCH-I545
android: 5.0.1

#*#4636#*#* does not work.
there's no place in Messaging app to show SMSC.

Worked with T-Mobile support and store employee for total of around 4 hours. They isolated to this being phone issue as SIM card was fine on a T-Mobile branded phone. A working SIM card from someone else would have the same problem on my phone. They also changed my SIM card a few times and it still didn't work either.

On call with Samsung support (Smart Tutor enabled so he can remotely control my phone), but he can't fix it either. He can't find any way to view nor change SMSC number. :(

Can someone help? Is there a programmatic way to change the SMSC directly?
 

donniedoomsday3

Well-known member
Jun 29, 2011
47
0
0
Visit site
I haven't been able to find a fix but I have been using Google voice to text with a different number from my phone its my only work a round I'm sorry :(

Posted via the Android Central App
 

nate_tran

New member
Sep 24, 2015
1
0
0
Visit site
Got the same exact problem. When I was running Kit-Kat I didn't have this problem, but when i manually updated the phone to lollipop, everything went downhill.
 

Lauretta Belk

New member
Sep 12, 2015
1
0
0
Visit site
I activated my phone with TMobile today and am having the same problem. Seems the problem is android; does anyone know if they're working on a patch for it? :/
 

Magicman08

Well-known member
May 4, 2011
136
8
0
Visit site
I found that I was only able to SEND texts on the Verizon S4 on AT&T's network when on H or H+ and not LTE. If I was on LTE sending text messages always failed. Kind of sucks but this phone was a HUGE upgrade from my HTC One XL in just about every aspect.

So I've learned to deal with it as I rarely am anywhere without wifi anyway and if I am I can manually switch to LTE and not send texts for a bit if I want to stream WWE network or SlingTv
 

vdots

New member
Oct 31, 2015
1
0
0
Visit site
Looks like you posted this a few months back, did you ever get outgoing text messaging to work for you? Were you able to reset the SMSC number? I have exactly the same issue.. went from Verizon to T-Mobile and lost text out capability. Talked to the store, T-mobile support, Samsung support, all in vain. Did anyone find you a way to update SMSC number?

Hi acannon420, did the new SIM cards work for you?
 
Last edited by a moderator:

Magicman08

Well-known member
May 4, 2011
136
8
0
Visit site
Did you read my post? I don't think it's possible...I have the "new" simcard and have done just about everything. AT&T anyway lte will not let me send text messages from the verizon s4
 

NewSeams

New member
Nov 4, 2015
1
0
0
Visit site
Same issue here. The only thing that is going to fix this is accessing and editing the Message Center. Without a fix or hack allowing users access to this, the problem will remain unsolved.
 

tehjosheh

Member
Dec 21, 2012
10
0
0
Visit site
I solved this issue for my girlfriend's phone on AT&T. Not sure if this exactly applies but here is what I learned/what i did:

After a few hours of research i discovered the issue was two fold:
1) Phone cannot send text messages through 4G (so disabling 4G LTE - i know this sux, and instead using HSPA - not thaaat bad)
2) Cannot change the SMSC phone number the texts will go through

Here is what I did:
1) Rooted her phone using Kingroot (very easy 1-click root tool)
2) Downloaded and installed the app Advanced Signal Status
3) Opened Advanced Signal Status app and clicked "Additional Info" (this opens the phone's hidden menu only accessible after rooting)
4) Under SMSC I changed the field to "+13123149810" for AT&T and pressed update ***Note you will have to find the corresponding number for TMOBILE
5) I changed the preferred network type from LTE/GSM to GSM Auto (this disables 4G LTE and only uses HSPA)
6) Restarted the phone and it was able to send SMS messages thereafter.

Hopefully this works for TMOBILE as well (not sure if they have HSPA coverage).

Good luck!
 

Srmeister

New member
Dec 1, 2015
1
0
0
Visit site
The rooting option worked! Kingroot and Advanced Signal Status - super easy and no hassles!

the t-mobile smsc number is +12063130004

Changed the data settings to GSM auto and it worked! Didn't have to reboot either.

tehjosheh Thank you for your hard work!
 

dreadful2

New member
Dec 12, 2015
1
0
0
Visit site
I was able to do all that (rooted, installed Adv Signal Status app & enter smsc #), but when I hit update, it would not save the number. Did you have any problem with this?
 

tehjosheh

Member
Dec 21, 2012
10
0
0
Visit site
I was able to do all that (rooted, installed Adv Signal Status app & enter smsc #), but when I hit update, it would not save the number. Did you have any problem with this?

i did not have that problem, sorry =/

pretend I am a 54 year old lady - okay I am a 54 year old lady...I downloaded Kingroot and Advanced signal status....how do I "root"?

once you download Kingroot you will need to install the app before you can root the phone. to do this you will first enter your phone's settings, go to security, and check the box that says "Unknown Sources". After this is done you will open the app "My Files" and navigate to where you downloaded the Kingroot app .apk file (likely it will be in your download folder). Once you locate the kingroot .apk file you will open it and follow the prompts to install the app. After Kingroot is installed, open the Kingroot app and select to root your device. After it shows it successfully rooted your device, restart your phone and proceed with my steps outlined above.
 
Last edited by a moderator:

Forum statistics

Threads
943,949
Messages
6,920,762
Members
3,159,325
Latest member
accessibilitys88