Charge looping Galaxy Tab S3

anon(10181084)

Well-known member
Mar 2, 2017
830
5
0
Visit site
So as of yesterday, everything was working OK on my tablet. So today I go to plug it in to top it up from 78% and it showed the little loading screen that comes up before the charging animation, and then the screen went blank. I tried multiple cables and chargers to no avail. It takes 5V 1.47A initially and decreases to 0.5 and shuts down. Tried to charge with the tablet on, and in that case it refused to charge and only too 500mA. After trying desperately to get it working, it started charge looping with the charge loading screen going on/off as if it is trying attempt after attempt to charge. The tablet is rooted and running a de-bloated stock ROM but I never modified anything regarding the charging system, and it has been charging fine (for the most part) until now when it just won't charge at all. I am suspecting maybe a faulty charger chip or something. Also, it doesn't see to enumerate with the Qualcomm QC on my charging station or power bank even though previously it would fast charge just fine from those. Is there anything I can do myself to fix this or will I have to hunt for a decent repair shop that can do component level repairs (I don't think any such place exists in my town and given current circumstances I cannot leave city limits).