Chromecast app can't find my chrome cast?

mvasquez009

Well-known member
Mar 21, 2013
195
0
0
Visit site
Ok so when I turn my tv to the input that it's plugged into my tv says ready to cast so say I go into YouTube play a video then decide to go into the chrome cast app I downloaded through Google play it tries to search for chrome cast devices that are on my wifi network but it can never find it? Then I get a screen on my phone that says can't find any connected chromecasts on your networks even though I'm still able to cast things

Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
Encountered this same problem for the first time today.
Its worked perfectly up to now.
No clue what went wrong.
Powered off chromecast and rebooted, still nothing.

Wait, per another thread, i rebooted the wifi router and Bam, it works.
 
Last edited:

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
Thanks I'll give it a try.. I'm using an apple airport extreme.

Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app

Are you on the 5ghz network, that won't work and will cause you issues. I had to connect to my 2.4ghz network to program everything.
 

Fres9056

Member
Aug 4, 2012
7
0
0
Visit site
Sorry bump an old thread but I finally got my chromecast after months of back order and now I wish I never got it. I am not sure how to switch my wifi from 5ghz to 2.4ghz but I have the same problem. Chromecast says ready to cast on tv but none of my devices can find it, Google chrome on my laptop, my iPad, nor my nexus 7. After 10 minutes or so of searching for chromecast over and over again, one device may finally find it and start working but that only if I'm lucky. What am I doing wrong? Or is this just a horrible product?
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
Reboot your router.
Sad to say, this is Google's last resort recommendation.

Sent from my HTC One X using Tapatalk 2
 

Devlyn16

Well-known member
Nov 11, 2010
985
1
0
Visit site
Sorry bump an old thread but I finally got my chromecast after months of back order and now I wish I never got it. I am not sure how to switch my wifi from 5ghz to 2.4ghz but I have the same problem. Chromecast says ready to cast on tv but none of my devices can find it, Google chrome on my laptop, my iPad, nor my nexus 7. After 10 minutes or so of searching for chromecast over and over again, one device may finally find it and start working but that only if I'm lucky. What am I doing wrong? Or is this just a horrible product?

What brand and model router do you have? Perhaps one of us can help you figure it out.

You may want to run a wi fi analyzer app on a mobile device to check the signal strength by the Chrome cast device.
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
Sorry bump an old thread but I finally got my chromecast after months of back order and now I wish I never got it. I am not sure how to switch my wifi from 5ghz to 2.4ghz but I have the same problem. Chromecast says ready to cast on tv but none of my devices can find it, Google chrome on my laptop, my iPad, nor my nexus 7. After 10 minutes or so of searching for chromecast over and over again, one device may finally find it and start working but that only if I'm lucky. What am I doing wrong? Or is this just a horrible product?

All 5ghz routers have 2 wifi networks for backwards compatible. One should be 2.4ghz the other 5ghz. If you can't tell the difference you need to go into your router's wifi settings to find out.
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
If your Chromecast says it is on the network and ready to cast then you Don't have a 5ghz problem.
The chromecast has already connected to the 2.4 ghz network.

Your other devices don't have to be on 2.4. They don't even have to be wireless. That is the job of the router.
Power off your router and power it back on as has been pointed out above.
That is Google's official solution till they get this fixed.

Sent from my A700 using Tapatalk 2
 

KristiK2

Member
Jun 1, 2013
6
0
0
Visit site
I'm having a similar issue and have almost given up on my Chromecast. Sometimes it works and most of the time it doesn't. I get the message that my device cannot connect with my Chromecast because they must be on two different networks. Not sure how it can work sometimes if the network is an issue. I have rebooted my router twice and that did seem to make it work temporarily, but my router is located inconveniently in a closet nook on the second floor and so I can't reboot every time I want to cast. Any other ideas out there?
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
I'm having a similar issue and have almost given up on my Chromecast. Sometimes it works and most of the time it doesn't. I get the message that my device cannot connect with my Chromecast because they must be on two different networks. Not sure how it can work sometimes if the network is an issue. I have rebooted my router twice and that did seem to make it work temporarily, but my router is located inconveniently in a closet nook on the second floor and so I can't reboot every time I want to cast. Any other ideas out there?

What do you mean by two different networks?
 

KristiK2

Member
Jun 1, 2013
6
0
0
Visit site
Not sure. That is the explanation my phone gives me during set up. It connects to my network (I see my network name pop up on my phone screen), but then after about 15 seconds of spinning, the app says it could not connect to my Chromecast because the two devices may be on different networks that can't communicate. This happens about 80% of the time I've tried to use it. I only have one network.
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
Not sure. That is the explanation my phone gives me during set up. It connects to my network (I see my network name pop up on my phone screen), but then after about 15 seconds of spinning, the app says it could not connect to my Chromecast because the two devices may be on different networks that can't communicate. This happens about 80% of the time I've tried to use it. I only have one network.

What router are you using?
 

KristiK2

Member
Jun 1, 2013
6
0
0
Visit site
I have a MacBook, but I am 2 OS updates behind for it to work on Chrome. I'm holding off upgrading because I may get a new MacBook soon. I'm just perplexed how it can work and then not work.
 

Farish

Well-known member
Apr 29, 2013
1,289
0
0
Visit site
I have a MacBook, but I am 2 OS updates behind for it to work on Chrome. I'm holding off upgrading because I may get a new MacBook soon. I'm just perplexed how it can work and then not work.

Well the cisco valet does offer a guest network feature but I am not sure if that is the actual problem or a wireless signal issue. If the Chromecast is far from the router, this would happen also as the signal fluctuates especially with interference from other channels.

One other suggestion is if possible change the channel of your router to 9 or greater(up to 11 is the option). But it may not work that great still.
 

KristiK2

Member
Jun 1, 2013
6
0
0
Visit site
FWIW, my Chromecast only seems to work immediately after rebooting my router. After a day or two, it can't communicate over my network. Hm.
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
FWIW, my Chromecast only seems to work immediately after rebooting my router. After a day or two, it can't communicate over my network. Hm.

Its a known bug. Google is working on it.
Some say unplugging the power to chromecast when not using it prevents having to reboot the router.
Whichever is easier.

Sent from my A700 using Tapatalk 2
 

Forum statistics

Threads
944,494
Messages
6,923,007
Members
3,159,581
Latest member
Hermes14