Crazy wake locks with 4.3

eronfaure

Well-known member
Jan 30, 2013
87
0
0
Visit site
Anyone else having crazy wakelocks, particularly with google services?

On only getting 2 hours of SOT now. I'm stock nexus 4 with 4.3.


Sent from my Nexus 4 using AC Forums mobile app
 

Attachments

  • 1375393332716.jpg
    1375393332716.jpg
    39.1 KB · Views: 96
  • 1375393345149.jpg
    1375393345149.jpg
    49.3 KB · Views: 95
  • 1375393356804.jpg
    1375393356804.jpg
    51.2 KB · Views: 94

eronfaure

Well-known member
Jan 30, 2013
87
0
0
Visit site
Shoot, forgot to post a pic of the wake locks. Here it is.

Sent from my Nexus 4 using AC Forums mobile app
 

Attachments

  • 1375411483739.jpg
    1375411483739.jpg
    63.9 KB · Views: 80

yubeie

Well-known member
Nov 27, 2010
259
0
16
Visit site
Great breakdown! Yes, I see the exact same behavior and have been scratching my head to alleviate this problem. Better Battery Stats actually produces a similar output..unfortunately I lost root on my phone and have been unable to drill down further.
I think its the location services which is causing this wake lock.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,553
4,683
113
Visit site
NLP seems to represent Natural Language Processing, which I think is involved with speech recognition. I wonder if it has to do with making the device listen for "Google," or "Ok Google Now"?
 

wunderbar

Well-known member
Dec 11, 2010
582
0
0
Visit site
do use google now a lot? The default behavior when you use google now is that when it comes up it turns on the mic and will accept voice commands after you say the word "google"

I always turn that off becuase I find google now just loads faster, and I never used it anyway. maybe try doing that. You can find it in the settings on google now. Scroll all the way to the bottom, hit the 3 dots, go to Voice, and turn off the hotword setting.
 

eronfaure

Well-known member
Jan 30, 2013
87
0
0
Visit site
I don't use Google now or a mic setting to justify that crazy amount of usage. I'll turn off the voice thing in Google now and see how it goes.

Sent from my Nexus 4 using AC Forums mobile app
 

Captainbob767

Well-known member
Dec 14, 2011
527
0
0
Visit site
Have you tried resetting your phone after the upgrade? I heard on a program on Android yesterday, that 4.3 now shows things that were happening in the background, without showing up in the status screen on 4.2.2 So the app programmers are scrambling to update their apps, so that these things won't be running in the background anymore.
 

gusar2000

Well-known member
Jun 4, 2013
152
0
0
Visit site
I noticed Google services/apps all bad in respect to deep sleep - they keep device from falling asleep :D
So I deactivated whatever I could :p
 

eronfaure

Well-known member
Jan 30, 2013
87
0
0
Visit site
It seems to be getting worse.

Sent from my Nexus 4 using AC Forums mobile app
 

Attachments

  • 1375465874601.jpg
    1375465874601.jpg
    47.8 KB · Views: 43
  • 1375465887475.jpg
    1375465887475.jpg
    54.9 KB · Views: 42

nickacs

Well-known member
Mar 28, 2010
585
1
0
Visit site
I downloaded 4.3 three days ago and so far so good...until today... I notice now for the last 5-6hrs that about 1/3 times I use the phone for something or SMS comes in that wakes up the screen, that when I'm done with whatever I'm doing, the screen doesn't sleep after the 30secs... Just stays on forever... Until I hit the power button to turn the screen off :( UGGG...
 

agp101

Well-known member
Jun 29, 2013
85
0
0
Visit site
I just resolved my problem. Same thing with the NLP thingy in Google services. I started off by turning off Google now, wifi/Mobile location in location access, as well as location reporting and history in Google settings. The problem went away and deep sleep was achieved finally for 85% of the time as opposed to 0% beforehand. Turned on mobile/WiFi location, then location reporting, and the problem hasn't come back. Google now is still disabled and quite frankly I didn't use it much buy I suspect it must be the culprit.

Posted via Android Central App
 

joshuauy

Member
Nov 25, 2010
12
0
0
Visit site
I have been seeing this same issue too. Does NLP stand for network location provider? I think it's more tied to location services for Google Now than listening for you to speak, but I could be wrong. I haven't noticed a difference between leaving "scanning always available" (for WiFi) on or off. I thought maybe that was the problem since I didn't see this issue on 4.2.2.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,553
4,683
113
Visit site
Does NLP stand for network location provider? I think it's more tied to location services for Google Now than listening for you to speak, but I could be wrong. I haven't noticed a difference between leaving "scanning always available" (for WiFi) on or off. I thought maybe that was the problem since I didn't see this issue on 4.2.2.

You may be right. When I initially searched for NLP, the only thing I came up with was Natural Language Processing (which could still make sense in relation to voice recognition). But Network Location Provider would also make sense.
 

agp101

Well-known member
Jun 29, 2013
85
0
0
Visit site
I have been seeing this same issue too. Does NLP stand for network location provider? I think it's more tied to location services for Google Now than listening for you to speak, but I could be wrong. I haven't noticed a difference between leaving "scanning always available" (for WiFi) on or off. I thought maybe that was the problem since I didn't see this issue on 4.2.2.

For me I found Google now was the culprit, I believe because it excessively used googles location reporting service through the nlpcollectorwakelock process.

I know that my deep sleep issues have been resolved since disabling Google now. Not sure exactly what NLP stands for though. Though I know it has to do with location. I have the WiFi/mobile data location checked, as well as googles location reporting. I've just left Google now disabled and my N4 now goes into deep sleep.

Posted via Android Central App
 

joshuauy

Member
Nov 25, 2010
12
0
0
Visit site
For me I found Google now was the culprit, I believe because it excessively used googles location reporting service through the nlpcollectorwakelock process.

I know that my deep sleep issues have been resolved since disabling Google now. Not sure exactly what NLP stands for though. Though I know it has to do with location. I have the WiFi/mobile data location checked, as well as googles location reporting. I've just left Google now disabled and my N4 now goes into deep sleep.

Posted via Android Central App

Yea, I agree. I think it's something location related and probably Google Now. It's just disappointing because it wasn't there in 4.2.2. You would just think a background improvements release like 4.3 wouldn't introduce an increase in wakelocks from background processes.
 

joshuauy

Member
Nov 25, 2010
12
0
0
Visit site
Joshuay, had your nlpwakelocks been as high as mine?

Sent from my Nexus 4 using AC Forums mobile app

Ever since I updated to 4.3, I have seen that NLP wakelock intermittently keep my phone from reaching deep sleep. Like for instance, my phone will be fine (able to reach deep sleep) for a few hours before hitting some state where it won't sleep until I reboot. I'm not sure what the problem is.

Although, today, I unchecked the "scanning always available" option just to see again if that could possibly be the problem, and so far, my phone has been able to get to deep sleep all day.

Sent from my Nexus 4 using Tapatalk 4
 

yubeie

Well-known member
Nov 27, 2010
259
0
16
Visit site
Disabling location reporting and location history along with the new wifi scanning option helped me... I am back to getting close to 15hrs with 45% remaining... and a 1.5hrs screen time with 2hrs phone time... Not bad I guess!

@Nexus4
Posted via Android Central App
 

jntnlevy

New member
Jul 27, 2013
1
0
0
Visit site
I also noticed the excessive appearance of NlpCollectorWakeLock while the Nexus should be in deep sleep.
After some investigations, using the BetterBatteryStats app, I found that by turning off the "Wifi and mobile network location" under Location access setting, the infamousNlpCollectorWakeLock does not appear to show up. I will let my device sleep through the night and see in the morning.