• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

DNS - can't get opendns family shield to be consistently used


Well-known member
May 22, 2011
I have had trouble with this on 2 phones. The phone is not consistently using the Opendns family shield servers for DNS.

The first phone was an old VM Optimus V, which was rooted, running Android 2.2 and using Harmonia ROM. I tried both SetDNS and DNS Changer apps to set the DNS to OpenDNS Family Shield DNS servers. It never did use the Opendns servers at all.

I now have a VM Supreme (ZTE phone) which I rooted, but stock ROM and Android 4.1.2. I have tried both SetDNS and DNS Changer apps and get inconsistent results. At least I've seen the Opendns warning about bad sites a couple times when testing it, but not consistently. It seemed to work better on the 3G/4G network and not at all on a hotel wifi, but now not it's not working at all. Is there a way to get the phone to always use the Opendns family shield server? When I'm connected to the hotel wifi, it never works...though it says it's using Opendns Family Shield, I can still get to all bad sites. Des this have something to do with the hotel wifi overriding my DNS settings?

I'm not sure what to do to fix this. I was thinking it may have been the apps, but I don't see where anyone else has complained about this, and then suspect something else since both apps do the same thing....inconsistent results, but mostly not working.

Anyone have ideas?
Last edited: