Do I need a new Battery

Kevi333

New member
Feb 27, 2014
2
0
0
Visit site
Im new to this forum so excuse me for any mistakes. Just yesterday my phone was charging perfectly without any problems. I did use it while it was charging though using Twitter and Ruzzle. Though today my phone started acting weird, it didnt charge at all. When I first connected it to the charger it started to drain the battery. A Couple hours later the battery has been drained by 30%. Now everytime I charge it it keeps depleting. I have no apps running, I turned mobile data off and have it on airplane mode. Right now its at 1% and says that its charging although i doubt it. So is the battery dead and I need a new one. The charger works fine as it is able to connect to the phone perfectly.
 

Eclipse2K

Well-known member
Mar 22, 2011
5,722
107
0
Visit site
Possibly. It could also be a faulty charger or charging port. Can you try another charger to see if it actually charges it properly?

Samsung Galaxy Note 3 (Verizon)
 

ffejjj

Well-known member
May 14, 2012
3,553
32
48
Visit site
Yep I agree. I'd stop by a local phone store and try a different charger and/or battery

Sent from my HTCONE using AC Forums mobile app
 

Kevi333

New member
Feb 27, 2014
2
0
0
Visit site
I tried different chargers on different outlets too. It did show the charging symbol but it continued to drain. the USB and Charger is not the problem.
 
Last edited:

Eclipse2K

Well-known member
Mar 22, 2011
5,722
107
0
Visit site
Could be the battery then. I've also seen it with a basic phone where this same thing happens and it's the battery. Go to your local store and see if they can test a different battery real quick. If this doesn't solve it than try a replacement device.

Samsung Galaxy Note 3 (Verizon)
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
If you turn the phone off completely and then connect the charger, do you see a static grey battery graphic, followed by another battery graphic showing the current battery level and charging activity?
It should take no more than two hours to fully charge in this configuration.

You could also try running down the battery until it's completely dead, then pull the battery for a few minutes and give it a full charge as indicated above - this should reset the battery calibration data.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
 

Trending Posts

Forum statistics

Threads
944,481
Messages
6,922,948
Members
3,159,575
Latest member
100RNR