eb01 superclean 2.4 stuck on boot loop with theme change

doctorj1

Active member
Dec 13, 2010
30
1
0
Visit site
I'm running eb01 with 2.4 superclean, everything was working great with CWM red. I was running the revolution theme and tried to switch themes. I made a back-up of what i was running and then flashed another theme. Got me stuck in a boot loop. Tried to wipe data/wipe cache. then flash my original back up but it puts me right back into the boot loop.

any ideas? i need help quick, gotta go to work. thanks guys. i really appreciate it
 

DroidXcon

Well-known member
Oct 21, 2010
11,102
3,392
0
Visit site
I'm running eb01 with 2.4 superclean, everything was working great with CWM red. I was running the revolution theme and tried to switch themes. I made a back-up of what i was running and then flashed another theme. Got me stuck in a boot loop. Tried to wipe data/wipe cache. then flash my original back up but it puts me right back into the boot loop.

any ideas? i need help quick, gotta go to work. thanks guys. i really appreciate it

flash superclean again , then after that restore the backup...themes get applied to the framework, it has nothing to do with your data or cache
 

Landshark

Well-known member
Jan 11, 2011
4,434
1,382
113
Visit site
I also have been having a major headache with this issue. I had a setup of superclean 2.4, touch of blue theme, full battery pop up disable, Adrynalyne's maintenance script, and nuance. Saved that as a nandroid backup. booted to red cwm created the same setup with blackish storm theme. stuck in force close boot loop at boot animation. Finally got it to work by flashing each thing separately and rebooting phone between each install. created a nandroid backup of that. Created two more nandroid backups of the same setup with nisuj17's blach Aosp and superdark themes. Tried restoring the nandroid backups and they all got stuck in a force close loop at boot animation except touch of blue.
 

baker12203

Active member
Nov 14, 2010
36
0
0
Visit site
I had this problem too, the only thing that seems to work is letting superclean load completely before flashing a theme over it. When I restored a backup, I had to reflash superclean, let it load, and then theme over it.
 

Landshark

Well-known member
Jan 11, 2011
4,434
1,382
113
Visit site
I had this problem too, the only thing that seems to work is letting superclean load completely before flashing a theme over it. When I restored a backup, I had to reflash superclean, let it load, and then theme over it.

Which pretty much defeats the whole purpose of a nandroid backup - being able to easily restore your phone to a previous or slightly different setup. Don't know if it's instability in the leaked ROM or what, but wish I or someone else could figure it out.
 

cpark_12

Well-known member
Feb 18, 2011
65
3
0
Visit site
I don't know that it's just a problem with flashing themes...if I reboot at all, I get in a forced close loop too...it didn't recognize any 3rd party apps. I haver to start from scratch and reinstall my apps after each reboot...kinds sucks

Sent from my Froyo'd Fascinate using Tapatalk
 

jackmei2

Well-known member
Sep 23, 2010
719
63
0
Visit site
yup, I had the same issue as you guys, which is why I asked which theme the OP flashed. I figured it was because VA Green was overwriting a lot of android apps was causing the issue.

I was on a bare SC 2.4 for a few days and finally decided to flash a theme, so I just booted into recovery and flashed VA Green, no wipes. I was getting a ton of haptic feedbacks like things were FC'ing. So I tried wiping everything, flashing SC2.4, flashing theme and then rebooting, but was getting a ton of FC's.

what I did to get it to work was:
1. wipe data, cache, dalvik cache
2. flash SC 2.4
3. boot up
4. reboot into recovery
5. flash theme
6. reboot

someone on XDA suggested that you can flash SC 2.4 and the theme and then wipe the caches and data and it should work. I haven't tried this yet. but it's weird, I've never had this issue before... I used to be able to flash themes at will so I thought it was VA Green theme causing this issue...
 

doctorj1

Active member
Dec 13, 2010
30
1
0
Visit site
yeah talk about frustrating, i felt like i finally had a pretty good grasp on what i was doing with CWM and i try to flash a simple theme and i'm stuck in boot loop. hopefully we can find a way around this soon. but yeah, i had to reflash the original SC2.4 then theme over it, couldn't switch from theme to theme.

thanks for the help guys
 

Landshark

Well-known member
Jan 11, 2011
4,434
1,382
113
Visit site
yup, I had the same issue as you guys, which is why I asked which theme the OP flashed. I figured it was because VA Green was overwriting a lot of android apps was causing the issue.

I was on a bare SC 2.4 for a few days and finally decided to flash a theme, so I just booted into recovery and flashed VA Green, no wipes. I was getting a ton of haptic feedbacks like things were FC'ing. So I tried wiping everything, flashing SC2.4, flashing theme and then rebooting, but was getting a ton of FC's.

what I did to get it to work was:
1. wipe data, cache, dalvik cache
2. flash SC 2.4
3. boot up
4. reboot into recovery
5. flash theme
6. reboot

someone on XDA suggested that you can flash SC 2.4 and the theme and then wipe the caches and data and it should work. I haven't tried this yet. but it's weird, I've never had this issue before... I used to be able to flash themes at will so I thought it was VA Green theme causing this issue...

Yeah, this is how I did it with blackish storm theme, flash one thing, reboot, boot to recovery, flash next thing, reboot, boot to recovery. Got everything on there, rebooted just fine, booted to recovery, did nandroid backup, did the other two setups, tried to reinstall blackish theme nandroid backup and..........force close loop at boot animation :mad:
 

doctorj1

Active member
Dec 13, 2010
30
1
0
Visit site
so unless someone figured out something that I haven't seen yet, backing up a theme/set up is worth jack right now because you have to flash the SC2.4 then put your theme on, right?

everyone is having trouble restoring themes that they have backed up?
you can switch to a different theme by flashing but you can't go back to your previous set up, you need to reflash it correct?
 

Landshark

Well-known member
Jan 11, 2011
4,434
1,382
113
Visit site
so unless someone figured out something that I haven't seen yet, backing up a theme/set up is worth jack right now because you have to flash the SC2.4 then put your theme on, right?

everyone is having trouble restoring themes that they have backed up?
you can switch to a different theme by flashing but you can't go back to your previous set up, you need to reflash it correct?

That seems to be what is happening. And even flashing a different theme isn't guaranteed to go off without a hitch. If the theme you are flashing too did not customize as many things as your previous theme, you may have remnants of you old theme left over. The only way to safeguard against that is to flash the rom and the theme whenever you change themes.
 

CeDj

Member
Sep 23, 2010
10
0
0
Visit site
I’m actually a little glad that I see others having issues with this. I never had problems before stacking themes when I was on DJO5, or DL30. I’m on SC 2.4v now and it was great until I tried different themes. Just as everyone else said, FCs up the wazoo. Luckily, I had a backup of just the SC 2.4 setup before any themes so I just gave up on the themes and went back to that. I could not figure out what I was doing wrong.
 

Trending Posts

Forum statistics

Threads
941,668
Messages
6,910,034
Members
3,158,018
Latest member
britneyvidson