Even the OEM charger slows my phone to a crippling hault...

KillerQ

Well-known member
Feb 23, 2011
1,091
24
0
Visit site
I can't believe this issue still exists on the Google pixel 2 XL

Whenever I plug my phone in, my phone instantly chokes and freezes and lags for a good FIVE minutes before I can use it.

If I unplug it, it works again instantly. This makes it useless when the battery is low.

Are other people still experiencing this issue?
 
Last edited:

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,278
22
0
Visit site
You say "still an issue" -- as in you have had it for awhile? I would have exchanged. I can charge at home, work (even while using), and in the truck and mine never chokes or freezes. That is not normal.

The charges I use at work/home at Pixel bricks that came w/ the Pixel 1 & 2. In the truck I just plug into my USB slots w/ an A to C anker cord.
 

KillerQ

Well-known member
Feb 23, 2011
1,091
24
0
Visit site
Thanks....

I was referring to the fact that there are other posts about people having this same issue.
 

cbreze

Well-known member
May 30, 2011
2,871
82
48
Visit site
First I've ever heard of this. I use mine on the charger every night, never had any problem.
How long has it been doing it?
 

Mooncatt

Ambassador
Feb 23, 2011
10,678
224
63
Visit site
First I've heard of it too. I use mine all the time when plugged in.

What phone do you have? I guess it's possible there's a line of phones out there with this bug, so knowing the device may help. It could also may be simply a bug on your specific phone. Try booting into safe mode and see if the problem still exists. If so, try factory resetting it and then see if the problem is there. And if that fails, time to exchange it, and hopefully through warranty if it's not too old.