Fix For Nexus 4 4.3 5ghz Wi-Fi issue

Tyler555

Active member
Nov 12, 2011
32
1
0
Visit site
Many of us including myself have found issues with the WiFi on the 5 ghz band upon upgrading to 4.3 I believe I have found a solution for at least some of us. What I did was took my router off of auto channel and put it on channel 48. Speeds went from <3 mbps to > 20 Mbps tested with speedtest.net. Channel 44 has also been reported to have worked as well. Please try this yourself and post back if it helped.

Original Forum:

https://productforums.google.com/forum/m/#!msg/mobile/X80hGyTmusI/g4dFCiYLrt4J

Posted via Android Central App
 

minnemike

Well-known member
Nov 29, 2012
861
0
0
Visit site
I have set my router for a fixed channel for bluetooth issues as well - seems the auto channel switching tech is not all that great in identifying conflicts.
 

itic

Well-known member
Feb 20, 2013
759
0
0
Visit site
wifi analyzer really helped me determine what channel to switch too b/c i have something like 5 competing networks within say 500' of my place.
 

pontiac005

Trusted Member
Jul 19, 2012
848
0
16
Visit site
wifi analyzer really helped me determine what channel to switch too b/c i have something like 5 competing networks within say 500' of my place.

Me too, had to switch to a higher channel

Sent from my Nexus 4 running Android 4.3 using Tapatalk 4
 

Tyler555

Active member
Nov 12, 2011
32
1
0
Visit site
Do you think Google will fix the problem in the next supplement update? Thanks for sharing your tip, I will be sure to try it.

They are usually pretty good about that. But it all depends. I have been having troubles with 2.4 GHz as well. I think it was the "power consumption" update they added to 4.3 that did it. So they may revise the code or simply rollback to 4.2 for wifi. Only time will tell though.
 

Jon Sid

Member
Mar 18, 2013
13
0
0
Visit site
Many of us including myself have found issues with the WiFi on the 5 ghz band upon upgrading to 4.3 I believe I have found a solution for at least some of us. What I did was took my router off of auto channel and put it on channel 48. Speeds went from <3 mbps to > 20 Mbps tested with speedtest.net. Channel 44 has also been reported to have worked as well. Please try this yourself and post back if it helped.

Original Forum:

https://productforums.google.com/forum/m/#!msg/mobile/X80hGyTmusI/g4dFCiYLrt4J

Posted via Android Central App

My speeds were 498kbps down and 1001kbps up when using 5ghz with Auto Channel in my router. I took your advice and tried to switch my Netgear N900 channel to 48 and a window popped up and told me that I would get my best speed if I set the channel between 149 and 165, so I set it to 149 and my speed took off - 7257kbps down and 1017kbps up. Thanks.
 

Chris Collins4

New member
Jun 1, 2013
4
0
0
Visit site
question and sorry if its really dumb.

how do I make my phone use 5ghz instead of 2.4?

is a s3, it supports 5gh, wifi analyzer shows 5ghz is available to use.

but my router shows my phone connected via 2.4ghz.

I cant find an option to choose 2.4 or 5ghz on phone.
 

zorak950

Well-known member
Feb 2, 2011
1,243
12
38
Visit site
If your phone supports it, it will show up as a separate network on your list of available access points. There's no 2.4/5 toggle, they're broadcast separately, with their own network names, passwords, and everything.
 

junglejunkie

Well-known member
Jun 17, 2010
629
37
0
Visit site
question and sorry if its really dumb.

how do I make my phone use 5ghz instead of 2.4?

is a s3, it supports 5gh, wifi analyzer shows 5ghz is available to use.

but my router shows my phone connected via 2.4ghz.

I cant find an option to choose 2.4 or 5ghz on phone.
It will be a different SSID (network) all together.
 

Chris Collins4

New member
Jun 1, 2013
4
0
0
Visit site
the ssid is same for both. when its shared it allows parallel access so faster speeds. but the phone is only using the 2.4ghz and I see no option to set to 5ghz.
 

fernandezhjr

Well-known member
Mar 26, 2011
936
19
0
Visit site
Idk about the S3, but with the N4, you go to Settings>Wi-Fi>hit the three dot menu and choose Advanced>Wi-Fi frequency band. There, you will have the option to choose auto, 5GHz only, or 2.4 GHz only. If you don't have this menu, it may not be supported, you don't have the option to choose, or the setting is located elsewhere.

Sent from my Nexus 4 using Tapatalk 4
 

Chris Collins4

New member
Jun 1, 2013
4
0
0
Visit site
yep its not in that menu. But it is on 4.0 roms, it dissapeared on 4.1.

so basically I found an app earlier (after I made first post) that allows it to be set. The dev of the app says the API is intact but samsung removed the option. So this app can choose either auto,2.4 or 5ghz. Auto always uses 2.4 on my phone. When I select 5ghz with this app it works and I get blazing speed. However it isnt stored, so if I turn off wifi and turn it on again, its back to auto (2.4).

I then tried making a unique ssid for 5ghz and the phone does connect to it but speeds are half of when using ssid shared.

Here is my internet speedtests.

2.4 - 15-30 (all over place as wifi congestion).
5 using seperate ssid - 30 stable at 30
5 using shared ssid and the app to select it - 60-65
 

feelfreetoblameme

New member
Sep 13, 2013
1
0
0
Visit site
Thanks for this, worked well for me on my Nexus 4. I had been investigating slow overall speeds on my wifi network anyway, and realized that on the 2.4 Ghz band, channel 6 was a bit crowded in my neighbourhood. Moved that to channel 1 but on my Nexus 4 I still had slow speeds on Speedtest compared to my laptop (phone was getting about 10 Mbps, laptop and desktops on wifi getting about 30 Mbps). When I changed the phone to access only the 2.4 Ghz signal, the speeds matched. I wanted to keep my setting on auto however to take advantage of the longer reach of 2.4 Ghz signal versus the 5 Ghz signal. I was on channel 149 on the 5 Ghz band, Wifi Analyzer (what a great app) recommended either 36 or 40. I changed it to channel 40 and now I am back to matching the speeds of my laptop/desktops on my phone. Great tip, cheers.
 

LazyEvul

Member
Nov 13, 2012
10
0
0
Visit site
Just tried this solution on my Nexus 4, unfortunately I can't seem to get it to cooperate with any channel on my 5GHz network. On 2.4GHz I can get 41 Mbps, but I struggled to exceed 4 Mbps on 5GHz. Oddly enough though, my upload stays pretty consistent on both (around 1Mbps, which is dismal but typical of ISPs around here), except for channel 153, when my upload came in as 0.01 Mbps.

I've tried all the channels available to me (36, 40, 44, 48, 149, 153, 157, 161) with no luck, although the double-digit channels are much faster than the triple-digits (I have yet to go any higher than 0.5 Mbps on a triple-digit channel, and even that is on the faster end of things). My PlayBook and Z10 worked just fine on all of them. Really hope Google sorts this out in Android 4.4.
 

g111

New member
Sep 30, 2013
1
0
0
Visit site
Hello,

I am not sure if my problem is the same as others have with 5GHz wifi. I have three Nexus 4 devices here. Two of them can see the 5GHz network fine and can connect to this. I do not know if the speed is ok though. But my problem: The third Nexus 4 can only see the 5GHz wifi sometimes. After one or some more seconds it disappears and then shows up again. This even happens right beside the wifi router (in 1m distance of it). The phone is not able to connect to the 5GHz wifi. Or it looses the connection after 2 seconds again.

I try to upload a screenshot of the wifi analyzer app:
Screenshot_2013-09-30-09-29-59.png
The pink curve is my 5GHz wifi signal. The red one is my 2.4GHz signal. The same scan on the the other two Nexus 4 phones does not show these gaps, instead the curve is continuesly on one level.

I already tried to switch from channel 36 to 44. But this did not change anything.
EDIT: The router is an Asus RT-AC66U.

What might be the problem here? Is this an hardware issue? Is it one of the known wifi driver problems in android 4.3? (But all phones do have the same android 4.3 OTA firmware. None is rooted or modified. Only one of the working phones has an unlocked bootloader as it had to be cleanly reflashed after a boot loop problem that came with the 4.3 OTA update).