Flashed Sony M4 Aqua - wrong software still works?

gwnius

New member
Feb 27, 2017
1
0
0
Visit site
I inherited a Sony M4 Aqua from a girlfriend leaving the country (going to a research station with no cell coverage anyway). Of course we lost contact and she had the phone locked.

I tried every hard reset instruction, but they all failed. I tried using the Sony "Emma" tool to get some diagnostics and it seemed like a step towards unlocking the bootloader, but it only actually loaded up once, and all I can remember from it was that the model number was not the usual Australian model# (which is 2303 – my vague recollection was that Emma showed it as E2353 – maybe a grey market Malaysian import?).

I dug it up again after a few months and tried Flashtool 10. I downloaded the E2353 firmware, and it failed to flash. I kept trying because I've seen these things work after a few attempts, and bang- it worked! Phone is operating on something called "Australian- Optimized" E2353 firmware. Looks very close to stock. Not locked to any network, so I got me a nice little extra handset here.

Now that I can actually see the IMEI, I checked it on IMEI.info. It came back as an E2303. When I check phone info in settings it says E2353, but that's probably grabbing info from the ROM anyway, so no help there.

A few questions for those in the know:

1. Are the 2303 and 2353 firmwares basically interchangeable?
2. Should I factory reset? If I do, will it go to my flashed ROM or the original factory ROM?
3. Should I re-flash with Flashtool 10 and the 2303 firmware?
4. Is IMEI.info just sometimes wrong?

Thanks for any help :D
 

Trending Posts

Forum statistics

Threads
941,571
Messages
6,909,439
Members
3,157,971
Latest member
Randal