Froyo Orientation Delay

dchawk81

Well-known member
Sep 5, 2010
619
31
0
Visit site
Has anyone else noticed a ~3 second delay in orientation change when not using the slide keyboard?

If so, has anyone found a fix?
 

wynand32

Well-known member
Dec 18, 2010
601
35
0
Visit site
Actually, now that you mention it the one delay I am getting is when using the slider. Takes a few seconds for the home screen items to redraw when going landscape and then when going back. Then again, I'm having that delay when exiting some apps as well...

I should say: I'm not getting any delay when switching orientation within apps (e.g., email, browser). That's pretty much instantaneous.
 

mikecornelius#AC

New member
Sep 12, 2010
1
0
0
Visit site
Download Terminal emulator from the market, then search the forum for (Epic 4g Screen lag). You will find very helpful information that will correct the screen lag. Of course I am rooted so I am not sure if this method can be used on a stock Epic.
 

dps

New member
Feb 22, 2011
1
0
0
Visit site
I noticed the same issue and sometime it just does it and goes to different orientation and have to shake it to get ti where it should be. Did calibration but still teh same issue.
 

dchawk81

Well-known member
Sep 5, 2010
619
31
0
Visit site
Download Terminal emulator from the market, then search the forum for (Epic 4g Screen lag). You will find very helpful information that will correct the screen lag. Of course I am rooted so I am not sure if this method can be used on a stock Epic.

Amazing, thanks!
 

dchawk81

Well-known member
Sep 5, 2010
619
31
0
Visit site
I was already rooted, so I don't know if it was necessary or not. Rooting is a simple process though if you do need it.
 

Addie_Goodvibes

Well-known member
Mar 11, 2010
429
61
0
Visit site
There is a setting to set the sensitivity of the accelerometer. I am not sure the exact steps, I will play around with it and edit my post, but I have seen this and done it before.

It's possible the default accelerometer settings with EB13 are slower.
 

seanp316

Member
Dec 8, 2010
7
2
0
Visit site
I was rooted with the leaked version of FROYO DK28 and noticed this 3 sec lag and tried to calibrated it with no success. I thought this issue would be fixed with the official update but can confirm that i am having the same 3 sec issue. This sucks
 

seanp316

Member
Dec 8, 2010
7
2
0
Visit site
Terminal process works but make sure that while doing the terminal process that the phone is laying down and i had to restart the phone after the terminal process and worked excellent.
 

DarkLupus

Member
Jan 13, 2011
6
0
0
Visit site
Epic 4G Froyo Auto-Rotate Slow?

After upgrading to 2.2 my epic aside from being slower in general...OS seems more sluggish the auto rotate takes way too long on my phone now like i turn the phone and on average im taking about 3-4 secs for it to change. I know it doesnt sound like a lot of time but for some things thats just way too long.

I'm thinking of either doing a hard reset and starting over OR going to a sprint store and getting it replaced cause ive been having issues with the usb connection as well
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
After upgrading to 2.2 my epic aside from being slower in general...OS seems more sluggish the auto rotate takes way too long on my phone now like i turn the phone and on average im taking about 3-4 secs for it to change. I know it doesnt sound like a lot of time but for some things thats just way too long.

I'm thinking of either doing a hard reset and starting over OR going to a sprint store and getting it replaced cause ive been having issues with the usb connection as well


The rotation lag is a product of Froyo. It was there in the leaked version of DK28 Froyo and they didn't address it on the official release. The only real way to fix it is by rooting you phone and using an application called Terminal Emulator.

Rotation Lag Fix:

Download Terminal Emulator from the Market

Type the following

su (press enter and allow root access)

/system/bin/sensorcalibutil_yamaha (press enter)

Then it will ask for you to calibrate. I usually lay mine flat on its back with keyboard open and then press enter. Back out of program and power off the screen then wake the phone up. Lag rotation fixed.
 

mouseglider

Well-known member
Dec 11, 2009
462
25
0
Visit site
I would like to add that you have to be rooted first, because as it is explained by Paul627g, it was confusing to me.

It seemed that you would type su in the terminal program and you should allow root access, but you have to be rooted first before the su command is valid.

Generally what I have seen, read, and done is: if you root, it will usally install busybox and superuser, ie su, then everything should work as stated.
 

ejohnnyk

Well-known member
Aug 11, 2010
193
5
0
Visit site
I had the same issue after I upgraded to DK28 and then used Odin to go back to stock 2.1.

But since I've upgraded to 2.2 -- the lag was still present -- I used the phone's Horizontal Calibration tool... and now the screen orientation is fast and responsive.

Menu>Settings>Display>Horizontal calibration

Give that a whirl before using the described method above, which will also fix things nicely.
 
Last edited:

Trending Posts

Forum statistics

Threads
943,022
Messages
6,916,920
Members
3,158,783
Latest member
hackdroid01