Galaxy Note update issues

Mordecai1331

New member
Mar 17, 2014
2
0
0
Visit site
Greetings,

I am using a Samsung Galaxy Note 2 SPH-L900 that currently has software 4.1.2. I've recently been trying to finally update to 4.3 and it seems my phone is stuck on an old update. It's 28.5MB and it'll show there's an update, I'll download it, it'll say it was successful. I'll then tell it to restart & install, what happens next is it looks like it just does a simply restart. It shuts off, shows the Samsung startup screen, and then I'm back to my homepage. Because of this, I can't update the phone any further. I tried going a Hard Reset (holding vol up, home, then power) and delete data/formating drive and that didn't fix it. I also tried going to the All Applications -> Google Services Framework -> Clear Cache -> Stop Service and what this does it brings up the same page for the 28.5MB download and it does the same thing it's always done.

My wife also has a Galaxy Note 2 and hers has the 4.3 update. This is on the Sprint network.

I've looked on the forums, I've looked through google, I can't seem to find a solution to this (I keep getting 4.3 info, my search parameters are probably not the best) so figured I'd make a post and hopefully someone can point me in the right direction.

Thanks!