Galaxy S3...Facebook won't load pictures on Newsfeed, etc unless connected to WIFI

Mendota Kid

New member
Aug 12, 2013
3
0
0
Visit site
On Saturday afternoon my 2 month old Galaxy S3 stopped downloading any pictures on Facebook newsfeed, notifications, etc...UNLESS I am connected to WIFI then they load perfectly...I uninstalled and reinstalled Facebook 4 times in the past 2 days...did a battery pull and finally went to the local Verizon store...people with LG, Droid and iphones had no problems...manager had a Samsung Galaxy Note and hers was doing the same grayed out areas where the pictures should be...she also had the problem begin Saturday afternoon...she said there should be an update notification or it will just start working again in a few days...she said not a Verizon issue but Facebook...anyone else have similar problems? if so, any fixes?
 

PaulBlackMetal

New member
Aug 16, 2013
1
0
0
Visit site
Same for me, and I even did a full phone factory reset and it still won't load photos on my news feed, notifications or in any groups. Must be something in the Facebook app that isn't jiving with the S3 because my girlfriends S4 is unaffected. Hopefully they update soon.
 

Mendota Kid

New member
Aug 12, 2013
3
0
0
Visit site
Magically started working again 2 days ago...pictures load slower, (2-3 seconds) but are now loading...you're correct...must be a Facebook issue and not anything wrong with the S3...Crazy how Facebook becomes a major influence in our lives.
 

hllon4whls

New member
Feb 3, 2011
3
0
0
Visit site
We were discussing this at work; we have an SIII, S4 and Moto HD MAXX. None of them populate pictures on 4G with good signal and speeds. Using one of the phones as a WiFi hotspot and all immediately populate pictures. All phones are Verizon as is the hotspot.
 
Last edited:

mullet4evr

Member
Jan 14, 2013
5
0
0
Visit site
This is getting to be a real annoyance. I'm with Verizon and am having the same issue on my GS3 for about a week now. News Feed loads fine, but the pics won't download. I sure hope an app update comes along or Verizon fixes their end!
 

DeniseRenee928

New member
Nov 17, 2013
1
0
0
Visit site
This is getting to be a real annoyance. I'm with Verizon and am having the same issue on my GS3 for about a week now. News Feed loads fine, but the pics won't download. I sure hope an app update comes along or Verizon fixes their end!

I'm having the same exact problem on my GS3 the last few days. Been trying everything on my phone to try to fix it. Glad it's not just me.
 

inventgm

New member
Jun 25, 2013
2
0
0
Visit site
This is happening on my goolge nexus 4 since kitkat update. Pictures wont load on any app. Even Youtube gives "There is some problem in network". No pictures are loading on FB, goolge+ or any other apps as well. Dont know why. After factory setup and using ADB also I was not able to solve the issue. Later after trying on multiple networks I found that I am facing this issue on my home's wifi connection. I tried to clear cache and even tried to reset and install the wifi router again then also it is not working. Its a very strange issue which I am facing. I also used some wifi fix apps but of no use. Can anyone suggest me on how to resolve the issue. Opening some sites gives ERR_NAME_NOT_RESOLVED error. But when I try to access the same site via my laptop or any other device (GS3, Note) it works fine.
Please suggest if anyone has come accorss any solution for this. Its really frustating....

Thanks.