Galaxy s3 - No power on, Won't Charge!

Erinn GainGreen

New member
Aug 11, 2013
Visit site
Hello everyone :) I purchased the galaxy s3 in november 2012 and in may 2013 i took a trip to the dominican republic. the phone was never dropped nor does it have water damage. I plugged my phone in one (muggy) night and when i woke up the next morning the phone was dead! I tried to plug it onto a charger again but the RED LED light came on for 2 minutes and shut down. I tried USB chargers and dock charger upon arrival to the US but nothing!!!!!!! It won't power on, read the USB cable, or charge :'( After those two minutes being on charge (its literally 2 mins every single time, i timed it!) the bottom of the phone by the charger in the back is kinda hot. I do have insurance on the phone (i think) but ALLLLL of my pictures from my vacation are on this phone!! and Sprint keeps telling me theres no way to retrieve them! (they're not on my google account and it wont read kies)

Sprint said they can't fix the phone because they'res a HAIRLINE crack in the silver HOUSING on the corner from my phone case snapping on and off.

someone PLEASEEEEEEEE help me!!

OOOH AND the red led light comes on even when the battery is removed :confused:
Last edited:


Well-known member
Jan 30, 2011
Visit site
Those Dominating Republicans are always causing someone grief...

Do you know anyone that has an external charger that you could charge the battery in?
I read in a different thread that someone had success by taking the battery out, connecting the phone to the charger, then putting the battery in (don't remember if they waited a couple of minutes before putting the battery in or not).

If the bottom of the phone is getting hot with the battery out and the phone plugged in (not even turned on), it sounds like your hardware is toast. If the pictures are that important you could do a search for JTAG - I think some guy offers that service, and that's the only thing I can think of to try if the phone won't power on at all. Sorry.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2

Forum statistics

Latest member