Galaxy S3 T999L Stuck on "T-Mobile 4G Lte" Screen


New member
Jun 4, 2013
Visit site
Hi guys, i'm hoping you can help me. I decided to factory reset my T999L Galaxy S3 last night to prepare to sell it. The "factory reset" option in settings was not working (I'd click it multiple times but nothing would happen) so since I knew it was possible to do a hard factory reset through recovery mode, I did just that. Also, I decided to wipe the cache partition. After doing both of these in recovery mode (factory data reset and wiping cache partition) I selected the option to reboot the device, but it just got stuck on the "T-Mobile 4G Lte"screen.

NB: [Literally in the middle of writing this, the phone somehow started working on its own LOL. I put it in download mode and was about to try and flash 4.3 firmware using Odin but I figured i'd ask here before I try that and end up bricking my device. I took it out of download mode to type up this question here and it booted but something different happened: it made the T-Mobile jingle noise which never happened previously. I figured this was some sign of improvement, so I left it and while it did get stuck on the "T-Mobile 4G Lte" screen again, after around 3 minutes it booted up normally to the "select language" screen. BULLET DODGED.

I do want to continue pointing out my original problem in case someone else in the same boat stumbles upon this thread. So after originally getting stuck on the "T-Mobile 4G Lte"screen, I did a battery pull and went back into recovery mode and tried another factory data reset, and noticed it said: "E: failed to mount /cache (invalid argument)" multiple times and in red text. I figured this was the main problem I was gonna be asking to fix, but as I mentioned before, somehow my problem worked itself out.

At the very least, thanks for reading :)

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Welcome to Android Central, and thanks for the details! I wonder, though, if this might be a red flag that either the firmware is becoming corrupt, or the hardware is starting to fail. It still might be worth reinstalling the firmware, either using Samsung Kies, or manually using Odin.

Forum statistics

Latest member
R. N.